summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-20 17:07:04 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-20 17:07:49 -0600
commit36ce5c81267a2880fd40e5d8e14c2c0122480083 (patch)
treeab21bafbec682a1734f5a7e04bf5b9be4096319f /sci-physics
parentmate-extra/mate-screensaver: Drop old (diff)
downloadgentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.tar.gz
gentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.tar.bz2
gentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.zip
sci-physics/hoomd-blue: make 2.0.1 work without git
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/hoomd-blue/Manifest2
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-2.0.1.ebuild26
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-9999.ebuild18
3 files changed, 27 insertions, 19 deletions
diff --git a/sci-physics/hoomd-blue/Manifest b/sci-physics/hoomd-blue/Manifest
index 045e7af7caec..b6969d68fa2f 100644
--- a/sci-physics/hoomd-blue/Manifest
+++ b/sci-physics/hoomd-blue/Manifest
@@ -1 +1,3 @@
DIST hoomd-blue-1.0.2.tar.bz2 2755462 SHA256 bca7d377fa152b5f99047c5701db0fecb244f56a7861c35eef0ded6106c520d1 SHA512 f9042e3afacc14e62490802d16a13a77592195befa61837703a39aeedf679e81f31aaafb377384d3b0a2f0e9e40dbce7ddd8b2673086706ba223fe265a2dff27 WHIRLPOOL b72c12a88941899c7a51a0a8e78783bf8c108b85f3969663453b2048a9a9c43ab8d4fd3fbcefa0a6d3add47ac880a2462d92760dc9efc5dd7a822be0252bce19
+DIST hoomd-blue-2.0.1.tar.bz2 3208100 SHA256 432cba74cde199f178dfadf7467738d356b83e1d5026c6c83c23880898c76019 SHA512 1edb634fd714c07401df98e6897c37638ac0a7205c10f9063866b2e759a550f5655cef2a62911020d22c7d089a5ab84456f6f7e05677f82bc37532389693ded7 WHIRLPOOL eb78fd60683591e913d0623f980486049cd69bb280724151f0158076863637b824bf29d522b03cb8a2ec9b246c5540553a5b3b65c9454a009529d261bd1a3130
+DIST libgetar-0.5.0.tar.bz2 217067 SHA256 8b03a352f63dcf8d14e88af758f65f71e5e4f92ed01c1566c3333da90164ab42 SHA512 a27de8f7c976e5578142319684de15afca47c24953f590b34cad4ef88c3778aa47aa5eb9a1f83b1473aa49f4394e45dfaa4a8b5107264fa93101dea78ec5fa6b WHIRLPOOL d5dbb0bc51bdc7241ba4c51461da0a54eb57b0e9f76e1f0a7127010ccbd375146b4aae0bfd98a431f96595459913168097502edc9d7fe60f3180ca56fb44e91a
diff --git a/sci-physics/hoomd-blue/hoomd-blue-2.0.1.ebuild b/sci-physics/hoomd-blue/hoomd-blue-2.0.1.ebuild
index e4dde6f1ccb2..30fe9f36fa21 100644
--- a/sci-physics/hoomd-blue/hoomd-blue-2.0.1.ebuild
+++ b/sci-physics/hoomd-blue/hoomd-blue-2.0.1.ebuild
@@ -7,50 +7,50 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils cuda flag-o-matic git-r3 python-single-r1
+inherit cmake-utils cuda flag-o-matic python-single-r1
DESCRIPTION="a general-purpose particle simulation toolkit"
HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
-if [[ ${PV} != 9999 ]]; then
- EGIT_COMMIT="v${PV}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ GETTAR_VER=0.5.0
+ SRC_URI="https://bitbucket.org/glotzer/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2
+ https://bitbucket.org/glotzer/libgetar/get/v${GETTAR_VER}.tar.bz2 -> libgetar-${GETTAR_VER}.tar.bz2"
PATCHES=( "${FILESDIR}/${P}-cxx11.patch" )
+ KEYWORDS="~amd64"
fi
LICENSE="hoomd-blue"
SLOT="0"
-IUSE="cuda test mpi +zlib"
+IUSE="cuda test mpi"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
mpi? ( virtual/mpi )
cuda? ( dev-util/nvidia-cuda-sdk )
- zlib? ( sys-libs/zlib )
dev-libs/boost:=[threads,python,mpi,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
- #doc? ( app-doc/doxygen )"
src_prepare() {
+ [[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
use cuda && cuda_src_prepare
-
cmake-utils_src_prepare
}
src_configure() {
local mycmakeargs=(
-DENABLE_MPI=$(usex mpi)
- -DENABLE_DOXYGEN=OFF #$(
-DENABLE_CUDA=$(usex cuda)
-DBUILD_TESTING=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
-DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
+ -DUPDATE_SUBMODULES=OFF
)
cmake-utils_src_configure
}
-
-src_install() {
- #use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/hoomd-*doc* )
- cmake-utils_src_install
-}
diff --git a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
index 5b01964b32c8..e126c82634de 100644
--- a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
+++ b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
@@ -7,31 +7,37 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils cuda flag-o-matic git-r3 python-single-r1
+inherit cmake-utils cuda flag-o-matic python-single-r1
DESCRIPTION="a general-purpose particle simulation toolkit"
HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
-if [[ ${PV} != 9999 ]]; then
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ GETTAR_VER=0.5.0
+ SRC_URI="https://bitbucket.org/glotzer/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2
+ https://bitbucket.org/glotzer/libgetar/get/v${GETTAR_VER}.tar.bz2 -> libgetar-${GETTAR_VER}.tar.bz2"
KEYWORDS="~amd64"
- EGIT_COMMIT="v${PV}"
fi
LICENSE="hoomd-blue"
SLOT="0"
-IUSE="cuda test mpi +zlib"
+IUSE="cuda test mpi"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
mpi? ( virtual/mpi )
cuda? ( dev-util/nvidia-cuda-sdk )
- zlib? ( sys-libs/zlib )
dev-libs/boost:=[threads,python,mpi,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
src_prepare() {
+ [[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
use cuda && cuda_src_prepare
cmake-utils_src_prepare
}
@@ -39,11 +45,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DENABLE_MPI=$(usex mpi)
- -DENABLE_DOXYGEN=OFF #$(
-DENABLE_CUDA=$(usex cuda)
-DBUILD_TESTING=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
-DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
+ -DUPDATE_SUBMODULES=OFF
)
cmake-utils_src_configure
}