summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-22 14:30:05 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-22 14:30:11 -0600
commit48013638ebb8cafa036106d6ed9c62db6e5fde77 (patch)
treec98f305dbf5e86bfa206f451adedadede847a159 /sci-physics
parentsys-cluster/hpx: added live ebuild from sci (diff)
downloadgentoo-48013638ebb8cafa036106d6ed9c62db6e5fde77.tar.gz
gentoo-48013638ebb8cafa036106d6ed9c62db6e5fde77.tar.bz2
gentoo-48013638ebb8cafa036106d6ed9c62db6e5fde77.zip
sci-physics/espresso: live ebuild update
Installed fixed in espressomd/espresso#749 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index 01c45af3b0b1..66a0214e6e55 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -69,6 +69,7 @@ src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
-DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
-DCMAKE_SKIP_RPATH=YES
+ -DLIBDIR=$(get_libdir)
)
cmake-utils_src_configure
}
@@ -82,14 +83,7 @@ src_compile() {
src_install() {
local i
- #https://github.com/espressomd/espresso/issues/733
- #cmake-utils_src_install
- dobin ${CMAKE_BUILD_DIR}/Espresso
- dolib.so "${CMAKE_BUILD_DIR}"/src/core/{,*}/lib*.so
- if use python; then
- insinto $(python_get_sitedir)/${PN}md
- doins -r "${CMAKE_BUILD_DIR}"/src/python/espressomd
- fi
+ cmake-utils_src_install
insinto /usr/share/${PN}/
doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
@@ -134,6 +128,6 @@ pkg_postinst() {
elog "and reemerge with USE=savedconfig"
echo
elog "For a full feature list see:"
- elog "/usr/share/${PN}/myconfig-sample.h"
+ elog "/usr/share/${PN}/myconfig-sample.hpp"
echo
}