summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 10:49:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-05 17:55:12 +0100
commit4cb38cbbb833f1509687a313cd7d9fea2bcb1056 (patch)
tree1bbc07bc0dc8e677f52f91c24c15024b9e185bd6 /sci-physics
parentsci-physics/clhep: Fix HOMEPAGE (diff)
downloadgentoo-4cb38cbbb833f1509687a313cd7d9fea2bcb1056.tar.gz
gentoo-4cb38cbbb833f1509687a313cd7d9fea2bcb1056.tar.bz2
gentoo-4cb38cbbb833f1509687a313cd7d9fea2bcb1056.zip
sci-physics/clhep: 2.2.0.5 EAPI-7 bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/clhep-2.2.0.5.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/sci-physics/clhep/clhep-2.2.0.5.ebuild b/sci-physics/clhep/clhep-2.2.0.5.ebuild
index 74d20855ced6..e73704e0e7a3 100644
--- a/sci-physics/clhep/clhep-2.2.0.5.ebuild
+++ b/sci-physics/clhep/clhep-2.2.0.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit cmake-utils multilib
+inherit cmake-utils
DESCRIPTION="High Energy Physics C++ library"
HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
@@ -13,9 +13,8 @@ SLOT="2/${PV}"
KEYWORDS="amd64 hppa ppc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="doc static-libs test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
+
+BDEPEND="doc? ( virtual/latex-base )"
S="${WORKDIR}/${PV}/CLHEP"
@@ -42,8 +41,8 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable test TESTING)
- $(cmake-utils_use doc CLHEP_BUILD_DOCS)
+ -DENABLE_TESTING=$(usex test)
+ -DCLHEP_BUILD_DOCS=$(usex doc)
)
DESTDIR="${ED}" cmake-utils_src_configure
use doc && MAKEOPTS+=" -j1"
@@ -51,5 +50,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
}