summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-12-12 21:10:14 +0100
committerGuilherme Amadio <amadio@gentoo.org>2021-12-14 15:58:24 +0100
commit544fcf2fbe461533e8842f380ffc8b5fce0a3ff0 (patch)
treef9c545cb598bd3e7de5727c3bd3b9415eac674bb /sci-physics
parentsci-physics/geant4_vmc: Bump to 5.4. (diff)
downloadgentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.tar.gz
gentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.tar.bz2
gentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.zip
sci-physics/vmc: Bump to 1.1_p1.
Also, switch to EAPI 8. Closes: https://github.com/gentoo/gentoo/pull/23277 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/vmc/Manifest1
-rw-r--r--sci-physics/vmc/vmc-1.1_p1.ebuild45
-rw-r--r--sci-physics/vmc/vmc-9999.ebuild2
3 files changed, 47 insertions, 1 deletions
diff --git a/sci-physics/vmc/Manifest b/sci-physics/vmc/Manifest
index aa34be22f3f2..8c7909cc790f 100644
--- a/sci-physics/vmc/Manifest
+++ b/sci-physics/vmc/Manifest
@@ -1 +1,2 @@
DIST vmc-1.0_p3.tar.gz 91476 BLAKE2B 3005e0575a5835b832175e6a272d4e3c328990e28ac998aca60a42c4ddd03faba4d1b761867d8af597ca2468cf3072c49bb007852b5ec892c215df37297656dc SHA512 621c0cb3f2846f9401e3e4fff6fa47ab2afbff7c4dca5c19869abb1806ec19d4a221e5741aad9b3929a4e8b8207ee6008a9bf06ec8bf03ed73771cb29fda1b8d
+DIST vmc-1.1_p1.tar.gz 91722 BLAKE2B 6849b52c95dd33393f75d24eb184571bfbc3b711e6bba7c33853493e97ad63fbdfa4c49c61f664b911d7e047229bcde08303b48a345f1a0b9bfffee3f078e275 SHA512 407d8a6d3c3375e448273750aaffe43e9f4a63cc2f4a4ec41d1cd9b3c830b836cbef8d4e9cb37e5a0595f54a22989b7e1dd62dda0606a84f5732d1d3f6eaaee8
diff --git a/sci-physics/vmc/vmc-1.1_p1.ebuild b/sci-physics/vmc/vmc-1.1_p1.ebuild
new file mode 100644
index 000000000000..548f95349c9c
--- /dev/null
+++ b/sci-physics/vmc/vmc-1.1_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="The Virtual Monte Carlo core library"
+HOMEPAGE="https://vmc-project.github.io/ https://github.com/vmc-project/vmc"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="c++11 c++14 +c++17 doc"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND="sci-physics/root:=[c++11?,c++14?,c++17?,-vmc]"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.md History)
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ # TRAVIS_BUILD_DIR hardcoded in Doxyfile by upstream.
+ TRAVIS_BUILD_DIR="${S}" doxygen doc/doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}
diff --git a/sci-physics/vmc/vmc-9999.ebuild b/sci-physics/vmc/vmc-9999.ebuild
index 6903ccfcbfdb..3598fb0ec8c0 100644
--- a/sci-physics/vmc/vmc-9999.ebuild
+++ b/sci-physics/vmc/vmc-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake