summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 09:43:17 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 09:43:17 +0100
commit80b26cc4b25e282d6dc115ea79aa0fa1bf4c9706 (patch)
tree60777842665a8b8aed43585946cd6de10eb112e7 /sci-physics
parentsci-chemistry/nmrglue: enable py3.11 (diff)
downloadgentoo-80b26cc4b25e282d6dc115ea79aa0fa1bf4c9706.tar.gz
gentoo-80b26cc4b25e282d6dc115ea79aa0fa1bf4c9706.tar.bz2
gentoo-80b26cc4b25e282d6dc115ea79aa0fa1bf4c9706.zip
sci-physics/yoda: add 1.9.7
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.9.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index d6600391198d..6cb5d1036f33 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1,3 +1,4 @@
DIST YODA-1.9.0.tar.bz2 1061105 BLAKE2B 70d68d31456747fcb14e27585aae245930061b5135b8a96c8ff3fe0375175d00a1c2d24a6c1ca3f18fc8464e610ef6287184f3990e12ff3fb108def600e34189 SHA512 eb82f1df832c2124dd81e07c06f165ddf13c4c4b70fcd0113f85045e22085d82751325bc57bfbd167649580980d98a15b666de56dada639160f24682b58b2f71
DIST YODA-1.9.5.tar.bz2 1077442 BLAKE2B 010ab725c57dfab8160e0304d461dc44c140d1ce234f3b70834ee58b8f269159529122095a94e6b79ef752612a6659a17e1874fda2941cfbcec1f53802916b6a SHA512 46e30b33d369f5d28ec228b71eaa298f3010cc06fe568785c74bbaf3d7468c26738cc2ee40da9bcc54d978f394187a2ee9289197283c86a3358583a3c0ecd247
DIST YODA-1.9.6.tar.bz2 1069530 BLAKE2B 23d782723c5b2429e9e9a70abe8dbf3d58a2204437a46b6e2e196cacc9b6ce55464d5600dd53492f43801866fc7da0e82d1e765cc04c493f40b2da95413aba25 SHA512 2433f2d685ccc97aa41e5f44e0c7ca560de01e3b746f2e4837ee6259cd142106e9aa0066aaa106e5298f8d4d9df3a09f5a2d058d6b1593792c9afe06b65d1a22
+DIST YODA-1.9.7.tar.bz2 1084794 BLAKE2B 86a1d061c6c16ceb994878d734642fe2be18dcce4391e7f8cb57df27b5944ba4edc6573915b150993c921a4a7b5eda2b3f598b7984466f6706348ca137e4981a SHA512 923e51a5783638304841bdc7aad6351c109c1806ce3f87d1ed9d965c4c95179bb1e416c9db77e39cd8f81417d08a7668cdde4f56cd893ce528b7cf9fe0e67c01
diff --git a/sci-physics/yoda/yoda-1.9.7.ebuild b/sci-physics/yoda/yoda-1.9.7.ebuild
new file mode 100644
index 000000000000..e812e9d72c77
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 autotools python-single-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+S="${WORKDIR}/${P^^}"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="root python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) root? ( python )"
+
+RDEPEND="
+ root? ( sci-physics/root:=[${PYTHON_SINGLE_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # reconf due to python3_10 patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable root) \
+ $(use_enable python pyext)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools to be installed already
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ # prevent double installation of python library
+ emake install DESTDIR="${ED}"
+ find "${ED}" -name '*.la' -delete || die
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion yoda
+ python_optimize
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+}