summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-04-24 19:29:11 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-04-27 16:18:56 +0300
commit938fbd296801a1a6fd5e9bde8ef7cb74b4b572a6 (patch)
tree7bfb5432e0a97e97657fe507b127f0c29decb784 /sci-physics
parentsys-kernel/vanilla-sources: add 5.17.5, drop 5.17.4 (diff)
downloadgentoo-938fbd296801a1a6fd5e9bde8ef7cb74b4b572a6.tar.gz
gentoo-938fbd296801a1a6fd5e9bde8ef7cb74b4b572a6.tar.bz2
gentoo-938fbd296801a1a6fd5e9bde8ef7cb74b4b572a6.zip
sci-physics/bullet: Bump to version 3.22b
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/25180 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/Manifest1
-rw-r--r--sci-physics/bullet/bullet-3.22b.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
index 0147de634410..5c5fc483463a 100644
--- a/sci-physics/bullet/Manifest
+++ b/sci-physics/bullet/Manifest
@@ -2,3 +2,4 @@ DIST bullet-3.07.tar.gz 148413637 BLAKE2B 776cd7651d11d865095ea000d353860bea09c6
DIST bullet-3.08.tar.gz 129282084 BLAKE2B daa5b6719575af28c6f6359ef51c7a9b8ca9cde2e5b4ea1b00c2991fc4d6b13175d034c7a694eaf36e8ff3ab343457027f57bb511639b3701341ad4551f1a6ca SHA512 4177c2b2f3b007691102973e7a3d4337b8de559d20058db75a2d25eab35b9be62fa14e3362435ef6f7ea2f6b8cf02a78770cc49c17e979adf3a2b41f19ee702a
DIST bullet-3.17.tar.gz 131995187 BLAKE2B 38996c299eb900f867367966c90c7511d4f5c727671249665a073f86390a4514f7c8193577fd73502b49d467eaeb6e7b195426089065ce3bda3238ee76e237b3 SHA512 a5105bf5f1dd365a64a350755c7d2c97942f74897a18dcdb3651e6732fd55cc1030a096f5808cf50575281f05e3ac09aa50a48d271a47b94cd61f5167a72b7cc
DIST bullet-3.21.tar.gz 133046747 BLAKE2B 7bbc51027f19502e4d72bb33ad698817d87d559b60a3eb1067aebc8e25dbf746fd99753cfe6839a2be649318ce7c7563f63409818dc1bdd210a5ed56fe38b5bd SHA512 dfe2e091d2ea42301e131b010769b5a3c5204693f40d46e4f2a8cba94117d19058b8c9873e6a1ce8dff11a249498e65540566ef1a2ff7866546289958965fda4
+DIST bullet-3.22b.tar.gz 139800935 BLAKE2B e7fb35d95b11164fd3184c110581bd73c0a4886087ccccd30b58756ffb97f79d1d2d1ae4a9f51b83c2eac94e5666b7529bf0dbfd7dd8a46ebcaed3f10edf76f5 SHA512 9e2f3eb78b94de6a11d605f4ab87868f19d5aa8df61b35030c3866d47ae9c3e5cfc56ab57b8752d697c17489599de55f4066125f3e1fcbcbc61eed8821ae3f24
diff --git a/sci-physics/bullet/bullet-3.22b.ebuild b/sci-physics/bullet/bullet-3.22b.ebuild
new file mode 100644
index 000000000000..236d0a1e53d8
--- /dev/null
+++ b/sci-physics/bullet/bullet-3.22b.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="https://pybullet.org/wordpress/"
+SRC_URI="https://github.com/bulletphysics/${PN}3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc double-precision examples extras openmp tbb test +threads"
+
+REQUIRED_USE="
+ openmp? ( threads )
+ tbb? ( threads )
+"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut
+ tbb? ( <dev-cpp/tbb-2021.4.0:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
+
+DOCS=( AUTHORS.txt LICENSE.txt README.md )
+
+# Building / linking of third Party library BussIK does not work out of the box
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_OPENGL3_DEMOS=OFF
+ -DBUILD_BULLET2_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DBUILD_BULLET3=ON
+ -DBUILD_BULLET_ROBOTICS_GUI_EXTRA=OFF # This module depends on example libraries
+ -DBUILD_EXTRAS=$(usex extras)
+ -DUSE_DOUBLE_PRECISION=$(usex double-precision)
+ -DBUILD_UNIT_TESTS=$(usex test)
+ -DBULLET2_MULTITHREADING=$(usex threads)
+ -DBULLET2_USE_OPEN_MP_MULTITHREADING=$(usex openmp)
+ -DBULLET2_USE_TBB_MULTITHREADING=$(usex tbb)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ doxygen || die
+ HTML_DOCS+=( html/. )
+ DOCS+=( docs/*.pdf )
+ fi
+
+ if use examples; then
+ # throws QA warnings
+ rm examples/ThirdPartyLibs/openvr/*/linux*/libopenvr_api.so || die
+ DOCS+=( examples )
+ fi
+}