summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2020-09-25 08:53:37 +0800
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:32 +0300
commitbb460dd3982b07543ecac94a1f0fa70f5d0ff340 (patch)
treecf4569321640e86aa81015d7924ee6cb579a9980 /sci-physics
parentsci-astronomy/stellarium: version 0.20.3 (diff)
downloadgentoo-bb460dd3982b07543ecac94a1f0fa70f5d0ff340.tar.gz
gentoo-bb460dd3982b07543ecac94a1f0fa70f5d0ff340.tar.bz2
gentoo-bb460dd3982b07543ecac94a1f0fa70f5d0ff340.zip
sci-physics/bullet: version bump to 3.05
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17657 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/Manifest1
-rw-r--r--sci-physics/bullet/bullet-3.05.ebuild86
-rw-r--r--sci-physics/bullet/metadata.xml8
3 files changed, 91 insertions, 4 deletions
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
index 56f16cbaf73f..7ebc2006eb69 100644
--- a/sci-physics/bullet/Manifest
+++ b/sci-physics/bullet/Manifest
@@ -1,2 +1,3 @@
DIST bullet-2.86.tar.gz 25806558 BLAKE2B a8576d8dacd67b9789d32d7b1acc6c4025df3c15427c60d66f98b1906eee8b2b94e5b0108b9a8c00ca6261510ccaf57ba5c02c72fee8f528d4f723b304166731 SHA512 af8a6b282ab606437d7975a59cd8a9c2bf273c83b0e79f0c4c1de6fa51695ba6d5f3c853dce2fdba9cb55e7572214e15089e54db51afc465ca26f502cbd5a4f9
DIST bullet-2.89.tar.gz 135742506 BLAKE2B 3725533bb50f3cf4783e21c57a5e3596f280d9aa3caa5b7a44925d4785206cc86514ff89c2cc1e33f8a14af7c8a5165190bb0515a6931fc4c7ec2e2b9aef3dd8 SHA512 3c4ba6a3b3623ef44dd4a23e0bc2e90dec1f2b7af463edcb886e110feac1dfb4a91945f0ed640052cac228318539e275976d37238102fb10a0f78aef065a730b
+DIST bullet-3.05.tar.gz 142858358 BLAKE2B d7ef2e68c0740e5bd2a728c576bcd3f07fff3680d8f604d7fd89bb6d7eb8c38f6205aea3bae300d70c2ec4e362c14e0567e3af3aabc893f8e33d979ffe8b3521 SHA512 4cb67547b466e01f6c2258b1f350fdfac0f2dc73a7962b6e196491e6722e1cd22cdfe80d7b2f4e1e92a90f91e277bff5cabfd0f55ef55010f9a4d7286843cecd
diff --git a/sci-physics/bullet/bullet-3.05.ebuild b/sci-physics/bullet/bullet-3.05.ebuild
new file mode 100644
index 000000000000..e44b181d40a5
--- /dev/null
+++ b/sci-physics/bullet/bullet-3.05.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples openmp tbb test threads"
+
+REQUIRED_USE="
+ openmp? ( threads )
+ tbb? ( threads )
+"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
+
+DOCS=( AUTHORS.txt LICENSE.txt README.md )
+
+# Building / linking of third Party library BussIK does not work out of the box
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_OPENGL3_DEMOS=OFF
+ -DBUILD_BULLET2_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DBUILD_BULLET3=ON
+ -DBUILD_EXTRAS=OFF
+ -DUSE_DOUBLE_PRECISION=ON
+ -DBUILD_UNIT_TESTS=$(usex test)
+ -DBULLET2_MULTITHREADING=$(usex threads)
+ -DBULLET2_USE_OPEN_MP_MULTITHREADING=$(usex openmp)
+ -DBULLET2_USE_TBB_MULTITHREADING=$(usex tbb)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ doxygen || die
+ HTML_DOCS+=( html/. )
+ DOCS+=( docs/*.pdf )
+ fi
+
+ if use examples; then
+ # throws QA warnings
+ rm examples/ThirdPartyLibs/openvr/*/linux*/libopenvr_api.so || die
+ DOCS+=( examples )
+ fi
+}
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
index 8dc1b6e634b1..3eb822b267c4 100644
--- a/sci-physics/bullet/metadata.xml
+++ b/sci-physics/bullet/metadata.xml
@@ -19,10 +19,10 @@
for games and animation.
</longdescription>
<use>
- <flag name="bullet3">Build Bullet 3</flag>
- <flag name="double-precision">Build libraries in double precision</flag>
- <flag name="extras">Build additional libraries</flag>
- <flag restrict="&gt;=sci-physics/bullet-2.89" name="tbb">Enable multithreading with the Intel Threads Building Block dev-cpp/tbb</flag>
+ <flag restrict="&lt;=sci-physics/bullet-2.89" name="bullet3">Build Bullet 3</flag>
+ <flag restrict="&lt;=sci-physics/bullet-2.89" name="double-precision">Build libraries in double precision</flag>
+ <flag restrict="&lt;=sci-physics/bullet-2.89" name="extras">Build additional libraries</flag>
+ <flag restrict="=sci-physics/bullet-2.89" name="tbb">Enable multithreading with the Intel Threads Building Block dev-cpp/tbb</flag>
</use>
<upstream>
<remote-id type="google-code">bullet</remote-id>