summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-13 23:51:11 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-13 23:51:11 +0100
commitd3f7bd8be84df9b66c787cdfbc8170f1c764c229 (patch)
tree9945e3b171a55d54f1204afb97dab3068721e597 /sci-physics
parentsci-physics/lhapdf: Bump to 6.3.0 (diff)
downloadgentoo-d3f7bd8be84df9b66c787cdfbc8170f1c764c229.tar.gz
gentoo-d3f7bd8be84df9b66c787cdfbc8170f1c764c229.tar.bz2
gentoo-d3f7bd8be84df9b66c787cdfbc8170f1c764c229.zip
sci-physics/yoda: Bump to 1.8.5
Closes: https://bugs.gentoo.org/732052 Closes: https://bugs.gentoo.org/725810 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.8.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 2aa93c634356..26c7828baa46 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.7.0.tar.bz2 949964 BLAKE2B 44063500b95e6a089adac0a28eb0165c6d91f09642dcba7eae994a8b2dd9c4cc5cff40d63cbb481f41e023193632b9b2c17c4304bc03afa4ad2c6010b52c15da SHA512 de4eff3fdd7f8f031745152907eadfe4687c6c8597772d8aba628e58e7d6f203bbe55ba030a77990b2441a9b046a4d7e2bce1fb29ba9a631c1cff17acd95b1e5
+DIST YODA-1.8.5.tar.bz2 1057576 BLAKE2B 3c6abb680afcfb8250c3ae340a1b1307cb5498b726199ecf9afe593fc49c4099fd2b4ac881568c303abd10c22fcf91ffae4283021443fc6230456376617f0de1 SHA512 d1fffa55af069f894b3c88bcd105f77a3105095281febf9c06c0cea2fadea6c63d69df5bde4aa96646d2d560bd83cade6802d9ed19d5a30553cd003ace19dfc8
diff --git a/sci-physics/yoda/yoda-1.8.5.ebuild b/sci-physics/yoda/yoda-1.8.5.ebuild
new file mode 100644
index 000000000000..5e3646209677
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.8.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+ newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
+ rm "${ED}"/usr/share/YODA/yoda-completion || die
+ rm -r "${ED}"/usr/etc || die
+}