summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-02-11 08:32:43 +0100
committerGuilherme Amadio <amadio@gentoo.org>2022-02-11 08:36:21 +0100
commite38b556f7cbba53976c8f488549c1aa6fc6d3f5d (patch)
treeaf42253dfb375139989d15f7a4bc7cef3c335f2c /sci-physics
parentsci-physics/geant4_vmc: Bump to version 6.0. (diff)
downloadgentoo-e38b556f7cbba53976c8f488549c1aa6fc6d3f5d.tar.gz
gentoo-e38b556f7cbba53976c8f488549c1aa6fc6d3f5d.tar.bz2
gentoo-e38b556f7cbba53976c8f488549c1aa6fc6d3f5d.zip
sci-physics/geant4_vmc: Drop oldest version
Closes: https://github.com/gentoo/gentoo/pull/24155 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant4_vmc/Manifest1
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/sci-physics/geant4_vmc/Manifest b/sci-physics/geant4_vmc/Manifest
index 7716ea9a285e..5e062fd6b1f2 100644
--- a/sci-physics/geant4_vmc/Manifest
+++ b/sci-physics/geant4_vmc/Manifest
@@ -1,3 +1,2 @@
-DIST geant4_vmc-5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
DIST geant4_vmc-5.4.tar.gz 7363185 BLAKE2B 3f1738a6d99d7cad1df1249a086b5257ff1d9c5c23657e12720b2d75ed61a96d6e45f2c964c471ba093d1c70fffb5b3df5a0d15fd7bdd54ab78a8f225649f0a1 SHA512 26b53c4b3a10943b9a5aa970dfc8c09b4086a385c6fea2a914bf8b020044032f9b73df7fd054185eba86f66ba50cd86372d0e874c0642bb3e357fba499fd7675
DIST geant4_vmc-6.0.tar.gz 5649857 BLAKE2B 905ee76a579e25ee6259aafe978b0f202313ae6ce7f62e424c663e5a22f3c77e9a2eb3a4d807515267087c9e95aebb962927728da8110248136d69bcb8b1fc56 SHA512 ee21ec2d493d4ef227b294818ca0e6940c437e069197009f4bfab0fa1c282b4ad0dc5744157077ccb3b8953c4a167492571a56f68def2152730bcb79892f56fc
diff --git a/sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild b/sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild
deleted file mode 100644
index fd749f52335a..000000000000
--- a/sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
-else
- MY_PV=$(ver_rs 1- -)
- SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${MY_PV}"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
-HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
-
-LICENSE="GPL-3"
-SLOT="4"
-IUSE="doc examples geant3 +g4root +mtroot vgm test"
-
-RDEPEND="
- <sci-physics/geant-4.11[c++17,opengl,geant3?]
- sci-physics/root:=[c++17,-vmc]
- <sci-physics/vmc-2.0:=[c++17]
- vgm? ( sci-physics/vgm:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-RESTRICT="
- !examples? ( test )
- !geant3? ( test )
- !g4root? ( test )
- !mtroot? ( test )
- !test? ( test )
- !vgm? ( test )"
-
-DOCS=(history README.md)
-
-src_configure() {
- local mycmakeargs=(
- -DGeant4VMC_USE_VGM="$(usex vgm)"
- -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
- -DGeant4VMC_USE_G4Root="$(usex g4root)"
- -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
- -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
- -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc ; then
- local dirs=(
- source
- $(usev g4root)
- $(usev mtroot)
- $(usev examples)
- )
- local d
- for d in "${dirs[@]}"; do
- pushd "${d}" > /dev/null || die
- doxygen || die
- popd > /dev/null || die
- done
- fi
-}
-
-src_test() {
- cd examples || die
- ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=(doc/.)
- einstalldocs
-}