summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-11-14 13:33:09 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-11-14 16:13:36 +0100
commite6da30824d2c3738ed215a22ee3f1619474bd6d1 (patch)
tree46a80243b504c99765573955c5a03e46a4dc93b5 /sci-physics
parentsci-physics/root: drop 6.28.06 (diff)
downloadgentoo-e6da30824d2c3738ed215a22ee3f1619474bd6d1.tar.gz
gentoo-e6da30824d2c3738ed215a22ee3f1619474bd6d1.tar.bz2
gentoo-e6da30824d2c3738ed215a22ee3f1619474bd6d1.zip
sci-physics/root: fix dependencies for USE=jupyter
Closes: https://bugs.gentoo.org/917264 Fixes: 4cf3d9955693efdf7c3f4f4fcff869886fbae6d8 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.28.08.ebuild13
-rw-r--r--sci-physics/root/root-6.28.9999.ebuild13
-rw-r--r--sci-physics/root/root-9999.ebuild13
3 files changed, 24 insertions, 15 deletions
diff --git a/sci-physics/root/root-6.28.08.ebuild b/sci-physics/root/root-6.28.08.ebuild
index f116da228820..32012c31e7b4 100644
--- a/sci-physics/root/root-6.28.08.ebuild
+++ b/sci-physics/root/root-6.28.08.ebuild
@@ -43,6 +43,7 @@ REQUIRED_USE="
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
davix? ( ssl xml )
+ jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
@@ -128,11 +129,13 @@ DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
- $(python_gen_cond_dep '
- dev-python/jupyter[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/metakernel[${PYTHON_USEDEP}]
- ')
+ jupyter? (
+ $(python_gen_cond_dep '
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/metakernel[${PYTHON_USEDEP}]
+ ')
+ )
"
PATCHES=(
diff --git a/sci-physics/root/root-6.28.9999.ebuild b/sci-physics/root/root-6.28.9999.ebuild
index f116da228820..32012c31e7b4 100644
--- a/sci-physics/root/root-6.28.9999.ebuild
+++ b/sci-physics/root/root-6.28.9999.ebuild
@@ -43,6 +43,7 @@ REQUIRED_USE="
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
davix? ( ssl xml )
+ jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
@@ -128,11 +129,13 @@ DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
- $(python_gen_cond_dep '
- dev-python/jupyter[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/metakernel[${PYTHON_USEDEP}]
- ')
+ jupyter? (
+ $(python_gen_cond_dep '
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/metakernel[${PYTHON_USEDEP}]
+ ')
+ )
"
PATCHES=(
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index f116da228820..32012c31e7b4 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -43,6 +43,7 @@ REQUIRED_USE="
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
davix? ( ssl xml )
+ jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
@@ -128,11 +129,13 @@ DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
- $(python_gen_cond_dep '
- dev-python/jupyter[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/metakernel[${PYTHON_USEDEP}]
- ')
+ jupyter? (
+ $(python_gen_cond_dep '
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/metakernel[${PYTHON_USEDEP}]
+ ')
+ )
"
PATCHES=(