summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-01-21 10:22:57 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-21 10:26:15 +0200
commiteb9db4c814d220be76f3ef11a5d69849ddb21ce7 (patch)
treebfb01db3ae94ad23fa90bc770155a3a4836ddc9b /sci-physics
parentpackage.mask: remove treecleaned package mask (diff)
downloadgentoo-eb9db4c814d220be76f3ef11a5d69849ddb21ce7.tar.gz
gentoo-eb9db4c814d220be76f3ef11a5d69849ddb21ce7.tar.bz2
gentoo-eb9db4c814d220be76f3ef11a5d69849ddb21ce7.zip
sci-physics/vgm: Bump to version 4.9.
This also fixes issues with the test suite in the live ebuild. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/18966 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/vgm/Manifest1
-rw-r--r--sci-physics/vgm/files/vgm-copy-test-seed.patch14
-rw-r--r--sci-physics/vgm/vgm-4.9.ebuild91
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild9
4 files changed, 112 insertions, 3 deletions
diff --git a/sci-physics/vgm/Manifest b/sci-physics/vgm/Manifest
index 717f6f9163e0..b03b99d0fe04 100644
--- a/sci-physics/vgm/Manifest
+++ b/sci-physics/vgm/Manifest
@@ -1 +1,2 @@
DIST vgm-4.8.tar.gz 3661965 BLAKE2B 29f878fb6716e261c27d60b2c9081d66313591a053d80f78501973f131aff88bbcee743ff9767836883dcb28d3ce5aeee3759a5890d7c8811a6a61503417284f SHA512 8b7cabc5796649c4014ccbdf1c6d209d2e7c2b4b06258716a72cadd997a9f6f51c4f9cb5870fd10abfd1ee133766876523c84441a69c7242bc2002687ca0ce58
+DIST vgm-4.9.tar.gz 3881029 BLAKE2B 596a8df12f0dcd813a0d84e8c33eaa92dd2d332d9accf2fc38992f385748a2bd3579fee2af6cc00b878fe5491af4996d80775aa630120507ccc665f102f63b11 SHA512 90845d75a7ff0022f5fba15b7f621efd588251060c0d8e715fcc2e28bb6b4b01ddd83420dbd233cc0dd437ee6b8b5390bb1f84571ed12e696ee8c1dfc4bd8fd9
diff --git a/sci-physics/vgm/files/vgm-copy-test-seed.patch b/sci-physics/vgm/files/vgm-copy-test-seed.patch
new file mode 100644
index 000000000000..31dcebdccde2
--- /dev/null
+++ b/sci-physics/vgm/files/vgm-copy-test-seed.patch
@@ -0,0 +1,14 @@
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 395eef0..bcf3a4a 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -76,7 +76,8 @@ set(VGM_TEST_SCRIPTS
+ test1_suite.sh
+ test2_suite.sh
+ test3_suite.sh
+- test_suite.sh)
++ test_suite.sh
++ startRun.rdm)
+
+ foreach(_script ${VGM_TEST_SCRIPTS})
+ configure_file(
diff --git a/sci-physics/vgm/vgm-4.9.ebuild b/sci-physics/vgm/vgm-4.9.ebuild
new file mode 100644
index 000000000000..c592bb49c348
--- /dev/null
+++ b/sci-physics/vgm/vgm-4.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+ KEYWORDS=""
+else
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND="
+ sci-physics/clhep:=
+ geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
+ root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? (
+ sci-physics/geant[gdml]
+ sci-physics/geant-vmc[g4root]
+ )"
+RESTRICT="
+ !geant4? ( test )
+ !root? ( test )
+ !test? ( test )
+ !examples? ( test )"
+
+DOCS=(
+ doc/README
+ doc/todo.txt
+ doc/VGMhistory.txt
+ doc/VGM.html
+ doc/VGMversions.html
+)
+PATCHES=(
+ "${FILESDIR}"/"${PN}-copy-test-seed.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_DIR="${EPREFIX}/usr"
+ -DWITH_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLES="$(usex examples)"
+ -DWITH_GEANT4="$(usex geant4)"
+ -DWITH_ROOT="$(usex root)"
+ -DWITH_TEST="$(usex test)"
+ )
+ if use test && use root && use geant4; then
+ mycmakeargs+=( -DWITH_G4ROOT=yes )
+ else
+ mycmakeargs+=( -DWITH_G4ROOT=no )
+ fi
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cd packages
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ # See upstream issue: https://github.com/vmc-project/vgm/issues/5
+ sed -i 's/ ScaledSolids / /' test3_suite.sh || die
+ PATH="${BUILD_DIR}"/test:$PATH ./test_suite.sh || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index 659728a149ea..e2d9d75a4f68 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,7 +38,8 @@ DEPEND="${RDEPEND}
RESTRICT="
!geant4? ( test )
!root? ( test )
- !test? ( test )"
+ !test? ( test )
+ !examples? ( test )"
DOCS=(
doc/README
@@ -75,7 +76,9 @@ src_compile() {
src_test() {
cd "${BUILD_DIR}"/test || die
- ./test_suite.sh || die
+ # See upstream issue: https://github.com/vmc-project/vgm/issues/5
+ sed -i 's/ ScaledSolids / /' test3_suite.sh || die
+ PATH="${BUILD_DIR}"/test:$PATH ./test_suite.sh || die
}
src_install() {