summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2021-04-21 16:03:46 +0200
committerGuilherme Amadio <amadio@gentoo.org>2021-04-21 16:12:03 +0200
commitf434ec9d1415100d289b4a9f15509637df051d37 (patch)
treeb33f263fb10156d2f25b124762e56f4cc3e05c9e /sci-physics
parentsys-apps/lshw: fix installation on prefix (diff)
downloadgentoo-f434ec9d1415100d289b4a9f15509637df051d37.tar.gz
gentoo-f434ec9d1415100d289b4a9f15509637df051d37.tar.bz2
gentoo-f434ec9d1415100d289b4a9f15509637df051d37.zip
sci-physics/root: update live ebuild
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/metadata.xml1
-rw-r--r--sci-physics/root/root-9999.ebuild19
2 files changed, 16 insertions, 4 deletions
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index 453df091a133..15ba329fe27c 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -42,6 +42,7 @@
<flag name="tbb">Enable implicit multi-threading (IMT) with <pkg>dev-cpp/tbb</pkg></flag>
<flag name="tmva">Built TMVA (ROOT's multi-variate analysis toolkit for machine learning)</flag>
<flag name="unuran">Enable support for <pkg>sci-mathematics/unuran</pkg></flag>
+ <flag name="uring">Enable support for <pkg>sys-libs/liburing</pkg> in RNTuple</flag>
<flag name="vc">Enable support for <pkg>dev-libs/vc</pkg> with VecCore</flag>
<flag name="vmc">Built the Virtual Monte Carlo library</flag>
<flag name="xrootd">Build the interface for <pkg>net-libs/xrootd</pkg> </flag>
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index ea14149330d7..dabb6bbd617f 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake cuda elisp-common fortran-2 prefix python-single-r1 toolchain-funcs
@@ -16,8 +16,8 @@ HOMEPAGE="https://root.cern"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda cudnn +davix debug emacs
+examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
- qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
- vmc +xml xrootd"
+ qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran uring
+ vc vmc +xml xrootd"
RESTRICT="!test? ( test )"
if [[ ${PV} =~ "9999" ]] ; then
@@ -46,6 +46,7 @@ REQUIRED_USE="
qt5? ( root7 )
root7? ( || ( c++14 c++17 ) )
tmva? ( gsl )
+ uring? ( root7 )
"
CDEPEND="
@@ -53,6 +54,7 @@ CDEPEND="
app-arch/zstd
app-arch/xz-utils
fortran? ( dev-lang/cfortran )
+ dev-cpp/nlohmann_json
dev-libs/libpcre:3
dev-libs/xxhash
media-fonts/dejavu
@@ -103,12 +105,13 @@ CDEPEND="
shadow? ( sys-apps/shadow )
sqlite? ( dev-db/sqlite:3 )
ssl? ( dev-libs/openssl:0= )
- tbb? ( >=dev-cpp/tbb-2018 )
+ tbb? ( dev-cpp/tbb )
tmva? (
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
')
)
+ uring? ( sys-libs/liburing )
vc? ( dev-libs/vc:= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( net-libs/xrootd:0= )
@@ -166,6 +169,8 @@ src_configure() {
-DCMAKE_INSTALL_LIBDIR="lib"
-DDEFAULT_SYSROOT="${EPREFIX}"
-DCLING_BUILD_PLUGINS=OFF
+ -Dasserts=OFF
+ -Ddev=OFF
-Dexceptions=ON
-Dfail-on-missing=ON
-Dgnuinstall=OFF
@@ -173,6 +178,8 @@ src_configure() {
-Dsoversion=ON
-Dbuiltin_llvm=ON
-Dbuiltin_clang=ON
+ -Dbuiltin_cling=ON
+ -Dbuiltin_openui5=ON
-Dbuiltin_afterimage=OFF
-Dbuiltin_cfitsio=OFF
-Dbuiltin_davix=OFF
@@ -184,6 +191,7 @@ src_configure() {
-Dbuiltin_gsl=OFF
-Dbuiltin_lz4=OFF
-Dbuiltin_lzma=OFF
+ -Dbuiltin_nlohmannjson=OFF
-Dbuiltin_openssl=OFF
-Dbuiltin_pcre=OFF
-Dbuiltin_tbb=OFF
@@ -208,6 +216,7 @@ src_configure() {
-Ddataframe=ON
-Ddavix=$(usex davix)
-Ddcache=OFF
+ -Ddistcc=OFF
-Dfcgi=$(usex http)
-Dfftw3=$(usex fftw)
-Dfitsio=$(usex fits)
@@ -251,6 +260,7 @@ src_configure() {
-Dsqlite=$(usex sqlite)
-Dssl=$(usex ssl)
-Dtcmalloc=OFF
+ -Dtest_distrdf_pyspark=OFF
-Dtesting=$(usex test)
-Dtmva=$(usex tmva)
-Dtmva-cpu=$(usex tmva)
@@ -258,6 +268,7 @@ src_configure() {
-Dtmva-pymva=$(usex tmva)
-Dtmva-rmva=$(usex R)
-Dunuran=$(usex unuran)
+ -During=$(usex uring)
-Dvc=$(usex vc)
-Dvdt=OFF
-Dveccore=OFF