summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/extrema
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/extrema')
-rw-r--r--sci-visualization/extrema/Manifest1
-rw-r--r--sci-visualization/extrema/extrema-4.4.5.ebuild58
-rw-r--r--sci-visualization/extrema/files/extrema-4.4.5-gcc46.patch15
-rw-r--r--sci-visualization/extrema/metadata.xml19
4 files changed, 93 insertions, 0 deletions
diff --git a/sci-visualization/extrema/Manifest b/sci-visualization/extrema/Manifest
new file mode 100644
index 000000000000..a934c66ea1ba
--- /dev/null
+++ b/sci-visualization/extrema/Manifest
@@ -0,0 +1 @@
+DIST extrema-4.4.5.tar.gz 6536157 SHA256 ce648d6531c3d55501078073e08a18d70e880b6329b5b168a59db5213d048491 SHA512 933caac15b511fc599366d42472d38bfce5031dbfa7bb7139bcd222268307f0141b18eb885948b39e52a6f06980ad7575cb9b56a31ad81d4cd7b2af291402e87 WHIRLPOOL 870235201d564aefe0c8352fb71b02177072f2bf5ad228e0e64553c1a45c0e48284a5284d6fc7af1348f01b865c1550e507df894b884c4f4fb764e2b1923966d
diff --git a/sci-visualization/extrema/extrema-4.4.5.ebuild b/sci-visualization/extrema/extrema-4.4.5.ebuild
new file mode 100644
index 000000000000..4f4c0b8997a2
--- /dev/null
+++ b/sci-visualization/extrema/extrema-4.4.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+WX_GTK_VER="2.8"
+inherit eutils fdo-mime wxwidgets
+
+DESCRIPTION="Interactive data analysis and visualization tool"
+HOMEPAGE="http://exsitewebware.com/extrema/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+# File collision, see bug #249423
+RDEPEND="!sci-chemistry/psi
+ x11-libs/wxGTK:2.8[X]
+ dev-util/desktop-file-utils"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/$(pkgdatadir)/$(DESTDIR)$(pkgdatadir)/g' \
+ src/Makefile.in || die
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+}
+
+src_configure() {
+ # extrema cannot be compiled with versions of minuit
+ # available in portage
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ make_desktop_entry ${PN}
+ dodir /usr/share/icons/hicolor
+ tar xjf extrema_icons.tar.bz2 -C "${ED}usr/share/icons/hicolor"
+ dosym ../../icons/hicolor/48x48/apps/extrema.png /usr/share/pixmaps/extrema.png
+
+ use doc && dodoc doc/*.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins Scripts/*.pcm Scripts/*.dat || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/extrema/files/extrema-4.4.5-gcc46.patch b/sci-visualization/extrema/files/extrema-4.4.5-gcc46.patch
new file mode 100644
index 000000000000..45a80429264b
--- /dev/null
+++ b/sci-visualization/extrema/files/extrema-4.4.5-gcc46.patch
@@ -0,0 +1,15 @@
+Fix building with gcc-4.6
+
+https://bugs.gentoo.org/show_bug.cgi?id=363467
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/src/Graphics/GRA_thiessenTriangulation.h
++++ b/src/Graphics/GRA_thiessenTriangulation.h
+@@ -19,6 +19,7 @@
+ #define GRA_THIESSENTRIANGULATION
+
+ #include <vector>
++#include <cstddef>
+
+ class GRA_thiessenTriangulation
+ {
diff --git a/sci-visualization/extrema/metadata.xml b/sci-visualization/extrema/metadata.xml
new file mode 100644
index 000000000000..56acf5b51a05
--- /dev/null
+++ b/sci-visualization/extrema/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>
+ Extrema is a powerful visualization and data analysis tool that
+ enables researchers to quickly distill their large, complex data sets
+ into meaningful information. Its flexibility, sophistication, and
+ power allow you to easily develop your own commands and create highly
+ customized graphs.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">extrema</remote-id>
+ </upstream>
+</pkgmetadata>