summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-05 09:30:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-05 11:06:03 +0200
commit02e0204b0f0ca608b56f4d5cdae06667405a116f (patch)
treed3066ff1c0fc38f75b795a35ce6b3f6fc2da7c31 /sci-visualization/labplot
parentdev-python/pastedeploy: Remove old (diff)
downloadgentoo-02e0204b0f0ca608b56f4d5cdae06667405a116f.tar.gz
gentoo-02e0204b0f0ca608b56f4d5cdae06667405a116f.tar.bz2
gentoo-02e0204b0f0ca608b56f4d5cdae06667405a116f.zip
sci-visualization/labplot: EAPI-8 bump, add IUSE=markdown,matio,origin
Upstream commits: 25bad33ab8cf30343fad9143412e8b238cb1bf32 06cefc9dc23a8f8896b9741ffc7704b9e2c2445b c9a155efaded430915d9770a72849a601d9f6a08 Update HOMEPAGE Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-visualization/labplot')
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild20
-rw-r--r--sci-visualization/labplot/metadata.xml3
2 files changed, 16 insertions, 7 deletions
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index 03cc30d425b1..6f96d8bbb4d3 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -11,7 +11,7 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
-HOMEPAGE="https://labplot.kde.org/ https://apps.kde.org/en/labplot2"
+HOMEPAGE="https://labplot.kde.org/ https://apps.kde.org/labplot2/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -19,13 +19,8 @@ fi
LICENSE="GPL-2"
SLOT="5"
-IUSE="cantor fftw fits hdf5 libcerf netcdf root serial telemetry"
+IUSE="cantor fftw fits hdf5 libcerf markdown matio netcdf origin root serial telemetry"
-# not packaged: dev-qt/qtmqtt, bug 683994
-BDEPEND="
- sys-devel/bison
- sys-devel/gettext
-"
DEPEND="
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
@@ -58,7 +53,10 @@ DEPEND="
fits? ( sci-libs/cfitsio:= )
hdf5? ( sci-libs/hdf5:= )
libcerf? ( sci-libs/libcerf )
+ markdown? ( app-text/discount )
+ matio? ( sci-libs/matio:= )
netcdf? ( sci-libs/netcdf:= )
+ origin? ( sci-libs/liborigin:2 )
root? (
app-arch/lz4
sys-libs/zlib
@@ -67,6 +65,11 @@ DEPEND="
telemetry? ( dev-libs/kuserfeedback:5 )
"
RDEPEND="${DEPEND}"
+# not packaged: dev-qt/qtmqtt, bug 683994
+BDEPEND="
+ sys-devel/bison
+ sys-devel/gettext
+"
src_configure() {
local mycmakeargs=(
@@ -77,7 +80,10 @@ src_configure() {
-DENABLE_FITS=$(usex fits)
-DENABLE_HDF5=$(usex hdf5)
-DENABLE_LIBCERF=$(usex libcerf)
+ -DENABLE_DISCOUNT=$(usex markdown)
+ -DENABLE_MATIO=$(usex matio)
-DENABLE_NETCDF=$(usex netcdf)
+ -DENABLE_LIBORIGIN=$(usex origin)
-DENABLE_ROOT=$(usex root)
-DENABLE_QTSERIALPORT=$(usex serial)
$(cmake_use_find_package telemetry KUserFeedback)
diff --git a/sci-visualization/labplot/metadata.xml b/sci-visualization/labplot/metadata.xml
index 44b4cb39dc37..1625558de1ee 100644
--- a/sci-visualization/labplot/metadata.xml
+++ b/sci-visualization/labplot/metadata.xml
@@ -20,6 +20,9 @@
<flag name="cantor">Enable support for different open-source computer algebra systems via <pkg>kde-apps/cantor</pkg></flag>
<flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
<flag name="libcerf">Enable special functions from <pkg>sci-libs/libcerf</pkg></flag>
+ <flag name="markdown">Enable Markdown support via <pkg>app-text/discount</pkg></flag>
+ <flag name="matio">Enable support for matio (<pkg>sci-libs/matio</pkg>)</flag>
+ <flag name="origin">Enable support for reading OriginLab OPJ project files through <pkg>sci-libs/liborigin</pkg></flag>
<flag name="root">Enable support for CERN's ROOT file type</flag>
<flag name="serial">Enable support for RS232 serial ports using <pkg>dev-qt/qtserialport</pkg></flag>
</use>