summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-09-19 22:00:46 -0500
committerMatthias Maier <tamiko@gentoo.org>2015-09-19 22:04:08 -0500
commita49857b0651a056274c2aab7f887dc7829bb64e3 (patch)
tree2582ddc4d4c09054e5f3939202471586dedb46da /sci-visualization/paraview/files
parentsci-visualization/paraview: Fix compilation with protobuf-2.6 (bug #537988) (diff)
downloadgentoo-a49857b0651a056274c2aab7f887dc7829bb64e3.tar.gz
gentoo-a49857b0651a056274c2aab7f887dc7829bb64e3.tar.bz2
gentoo-a49857b0651a056274c2aab7f887dc7829bb64e3.zip
sci-visualization/paraview: Fix compile for "development -python", bug #560670
Thanks to Dion Moult for tracking this down. Gentoo-Bug: 560670 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-visualization/paraview/files')
-rw-r--r--sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch b/sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch
new file mode 100644
index 000000000000..4bc5e546fc9d
--- /dev/null
+++ b/sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=560670
+http://www.paraview.org/Bug/view.php?id=15655
+
+diff --git a/Qt/Components/CMakeLists.txt b/Qt/Components/CMakeLists.txt
+index c45b4bf..8616a90 100644
+--- a/Qt/Components/CMakeLists.txt
++++ b/Qt/Components/CMakeLists.txt
+@@ -650,7 +650,7 @@ vtk_module_library(${vtk-module}
+ #the pqSGExportStateWizard has subclasses that directly access
+ #the UI file, and currently we don't have a clean way to break this hard
+ #dependency, so for no we install this ui file.
+-if(PARAVIEW_INSTALL_DEVELOPMENT_FILES)
++if(PARAVIEW_INSTALL_DEVELOPMENT_FILES AND PARAVIEW_ENABLE_PYTHON)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ui_pqExportStateWizard.h"
+ DESTINATION "${VTK_INSTALL_INCLUDE_DIR}")
+ endif()