summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2016-02-06 17:08:00 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2016-02-06 17:08:00 +0100
commit12a7a212fba784a6061a29c902310c3aa06bc255 (patch)
treebc76f9b104cc6635aec0ac8dd0127de17cd3b7cf /sci-visualization/pythonprop/pythonprop-0.18.ebuild
parentkde-apps/kmail: Shorten DESCRIPTION (diff)
downloadgentoo-12a7a212fba784a6061a29c902310c3aa06bc255.tar.gz
gentoo-12a7a212fba784a6061a29c902310c3aa06bc255.tar.bz2
gentoo-12a7a212fba784a6061a29c902310c3aa06bc255.zip
sci-visualization/pythonprop: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-visualization/pythonprop/pythonprop-0.18.ebuild')
-rw-r--r--sci-visualization/pythonprop/pythonprop-0.18.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-visualization/pythonprop/pythonprop-0.18.ebuild b/sci-visualization/pythonprop/pythonprop-0.18.ebuild
new file mode 100644
index 000000000000..2377cd0135d7
--- /dev/null
+++ b/sci-visualization/pythonprop/pythonprop-0.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Scripts to prepare and plot VOACAP propagation predictions"
+HOMEPAGE="http://www.qsl.net/hz1jw/pythonprop"
+SRC_URI="http://www.qsl.net/h/hz1jw/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/basemap[${PYTHON_USEDEP}]
+ sci-electronics/voacapl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # do not call update_destop_database here
+ sed -ie "s/UPDATE_DESKTOP = /UPDATE_DESKTOP = # /g" data/Makefile.in || die
+ # fix Desktop Entry
+ sed -ie "s/HamRadio/HamRadio;/g" data/voacapgui.desktop.in || die
+}