summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 20:13:09 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:39 +0100
commitce95489b3535a06db2f503055060d52bf48db30d (patch)
treed9b2c3d35066b6239ddd39fb70d50b0cca006f7e /sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild
parentsci-visualization/paraview: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-ce95489b3535a06db2f503055060d52bf48db30d.tar.gz
gentoo-ce95489b3535a06db2f503055060d52bf48db30d.tar.bz2
gentoo-ce95489b3535a06db2f503055060d52bf48db30d.zip
sci-visualization/pyxplot: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild')
-rw-r--r--sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild b/sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild
new file mode 100644
index 000000000000..7cc957e134be
--- /dev/null
+++ b/sci-visualization/pyxplot/pyxplot-0.9.2-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Gnuplot like graphing program publication-quality figures"
+HOMEPAGE="http://www.pyxplot.org.uk/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ app-text/gv
+ dev-libs/libxml2:2
+ media-libs/libpng:0=
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0=
+ sci-libs/gsl
+ $(python_gen_cond_dep '
+ || (
+ sci-libs/scipy-python2[${PYTHON_MULTI_USEDEP}]
+ sci-libs/scipy[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+ virtual/latex-base
+ virtual/imagemagick-tools
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed \
+ -e "s:/usr/local:${EPREFIX}/usr/:" \
+ -e "s:/lib/:/$(get_libdir)/:" \
+ -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i Makefile.skel || die "sed Makefile.skel failed"
+ sed -i -e 's/-ltermcap//' configure || die
+}