summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-06 12:05:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-06 12:08:36 +0200
commit4bd19add6f3bb153e4ecd28c1fa0c063824e95c7 (patch)
tree5c7d830bb2800591084c41687d5df718b82b2997 /sci-visualization/veusz
parentdev-python/h5py: enable py3.11 (diff)
downloadgentoo-4bd19add6f3bb153e4ecd28c1fa0c063824e95c7.tar.gz
gentoo-4bd19add6f3bb153e4ecd28c1fa0c063824e95c7.tar.bz2
gentoo-4bd19add6f3bb153e4ecd28c1fa0c063824e95c7.zip
sci-visualization/veusz: add 3.4.99, enable py3_{10,11}, pep517
This is technically a pre-release, but it fixes the problem where we cannot compile with sip-6. sip-5 is no longer in the tree The in-tree version of veusz cannot compile when sip:5 is present Closes: https://bugs.gentoo.org/846302 Closes: https://bugs.gentoo.org/823005 Closes: https://bugs.gentoo.org/831663 Closes: https://bugs.gentoo.org/815421 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization/veusz')
-rw-r--r--sci-visualization/veusz/Manifest1
-rw-r--r--sci-visualization/veusz/veusz-3.4.99.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-visualization/veusz/Manifest b/sci-visualization/veusz/Manifest
index 41616f313ece..648b950d0e3c 100644
--- a/sci-visualization/veusz/Manifest
+++ b/sci-visualization/veusz/Manifest
@@ -1 +1,2 @@
DIST veusz-3.3.1.tar.gz 3249376 BLAKE2B d3113a4f5f6a2fc3460e73b6b99d6353d6a0745a0d3cc0f276a86cb6fcef369bb74ca34aa205c69e7755dbe6d6fa6dce3ff267ca075f211c8635cab0350233a5 SHA512 a2fa204a33ae0dac98907c3af88b24f322849360e30c05101bbfa6307dc8aa6fdec580f060fc9cd9921f7706db51419efe088f927d22db860419eea4e0f4e84c
+DIST veusz-3.4.99.tar.gz 3320917 BLAKE2B 3ef3a7333009040f0d66b94cb6220becfb04e7957dcc7586326b178c1b3f5442b722fdfb8b7a1e5172a3b38c1c3d85cad52be8eeb3181d603abf0382da5b21f2 SHA512 e854d6dae32bb76caa713439ff2139c7f9797d6be72e6c88f48491c385372c4f776c0d1d183b13bc818538e6271f4daab04b630589d635adc22e8aa8380c70b8
diff --git a/sci-visualization/veusz/veusz-3.4.99.ebuild b/sci-visualization/veusz/veusz-3.4.99.ebuild
new file mode 100644
index 000000000000..958196fca5e2
--- /dev/null
+++ b/sci-visualization/veusz/veusz-3.4.99.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 qmake-utils virtualx xdg
+
+DESCRIPTION="Qt scientific plotting package with good Postscript output"
+HOMEPAGE="https://veusz.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus hdf5"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[widgets,svg,printsupport,${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/sip:5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx Documents/manual-source \
+ dev-python/alabaster
+
+src_prepare() {
+ distutils-r1_src_prepare
+ xdg_environment_reset
+}
+
+python_compile() {
+ distutils-r1_python_compile build_ext --qmake-exe=$(qt5_get_bindir)/qmake
+}
+
+python_test() {
+ VIRTUALX_COMMAND="${EPYTHON}" \
+ VEUSZ_RESOURCE_DIR="${S}" \
+ virtx tests/runselftest.py
+}
+
+python_install() {
+ distutils-r1_python_install
+ # symlink the license, bug #341653
+ rm "${D}/$(python_get_sitedir)"/${PN}/{COPYING,AUTHORS,ChangeLog} || die
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+ cat >> "${D}/$(python_get_sitedir)"/${PN}/COPYING <<- EOF
+ Please visit
+
+ https://www.gnu.org/licenses/gpl-2.0.html
+
+ for the full license text.
+ EOF
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doicon icons/veusz.png
+ domenu "${FILESDIR}"/veusz.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/veusz.xml
+}