summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/xd3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/xd3d')
-rw-r--r--sci-visualization/xd3d/Manifest1
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch41
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff86
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch61
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch10
-rw-r--r--sci-visualization/xd3d/metadata.xml13
-rw-r--r--sci-visualization/xd3d/xd3d-8.3.1.ebuild56
7 files changed, 268 insertions, 0 deletions
diff --git a/sci-visualization/xd3d/Manifest b/sci-visualization/xd3d/Manifest
new file mode 100644
index 000000000000..18ef77192a30
--- /dev/null
+++ b/sci-visualization/xd3d/Manifest
@@ -0,0 +1 @@
+DIST xd3d-8.3.1.tar.gz 2188216 SHA256 f363cabec88fb5055fe86fb9973d7122e93dfd4a803517b9f90be18131ef8816 SHA512 a02e1b53b1d393c8184866b0693394f596bb3c1eb5f49d00a41dd7bb972f08ba8d1621e7a1f197b015551d9483c9c76c07dac5e199961de775b9ff63c898c89e WHIRLPOOL de1ffd61ee99bc12474a37e37049ceec0d7f36a4d0095f556f2cbffb407cc90f98540052bb7a31666387d310ee169fd06cba68b18dd633583148e46664e74419
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch
new file mode 100644
index 000000000000..b62129b41bf4
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-cflags.patch
@@ -0,0 +1,41 @@
+ src/various/Makefile | 16 ++++++++--------
+ 1 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/src/various/Makefile b/src/various/Makefile
+index 7188b2a..80f47ec 100644
+--- a/src/various/Makefile
++++ b/src/various/Makefile
+@@ -3,25 +3,25 @@ include ../../RULES
+ all :; make clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
+
+ clair : clair.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/clair $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/clair $(FCFLAGS) $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
+
+ clairc3d : clairc3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/clairc3d $(INCF) clairc3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/clairc3d $(FCFLAGS) $(INCF) clairc3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ create_c3d : create_c3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/create_c3d $(INCF) create_c3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/create_c3d $(FCFLAGS) $(INCF) create_c3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ obscur : obscur.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/obscur $(INCF) obscur.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/obscur $(FCFLAGS) $(INCF) obscur.f $(LIBRAIRIE) $(LINKOPTX)
+
+ obscurc3d : obscurc3d.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/obscurc3d $(INCF) obscurc3d.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/obscurc3d $(FCFLAGS) $(INCF) obscurc3d.f $(LIBRAIRIE) $(LINKOPTX)
+
+ tradavoir : tradavoir.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/tradavoir $(INCF) tradavoir.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/tradavoir $(FCFLAGS) $(INCF) tradavoir.f $(LIBRAIRIE) $(LINKOPTX)
+
+ translation : translation.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/translation $(INCF) translation.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/translation $(FCFLAGS) $(INCF) translation.f $(LIBRAIRIE) $(LINKOPTX)
+
+ txt2avoir : txt2avoir.f $(LIBRAIRIE) ;\
+-$(LINK) $(BINDIR)/txt2avoir $(INCF) txt2avoir.f $(LIBRAIRIE) $(LINKOPTX)
++$(LINK) $(BINDIR)/txt2avoir $(FCFLAGS) $(INCF) txt2avoir.f $(LIBRAIRIE) $(LINKOPTX)
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
new file mode 100644
index 000000000000..4e7c52b7724a
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
@@ -0,0 +1,86 @@
+diff -Naur RULES.gentoo RULES.gentoo
+--- RULES.gentoo 1969-12-31 19:00:00.000000000 -0500
++++ RULES.gentoo 2008-01-21 06:41:41.000000000 -0500
+@@ -0,0 +1,82 @@
++#--------------------------------------------------------
++# Configuration file for the Makefiles of xd3d |
++# François Jouve 2005 (Francois.Jouve@Polytechnique.fr) |
++#--------------------------------------------------------
++
++#
++# Modifiable parameters
++#
++
++#
++# Root directory of the distribution
++#
++#XD3D_DIR = $(HOME)/xd3d-8.1.0
++XD3D_DIR = Please_Configure
++
++#
++# Install directory
++#
++#INSTALL_DIR = /usr/local/bin
++INSTALL_DIR = ##D##/usr/bin
++
++#
++# Location of the X11 lib (libX11.a)
++#
++#LIBX11 = /usr/X11R6/lib
++LIBX11 = /usr/##lib##/
++
++#
++# Language parameter
++#
++#LANGUAGE = FRANCAIS
++#LANGUAGE = ENGLISH
++LANGUAGE = ENGLISH
++
++#
++# Max memory for xd3d (MBytes)
++#
++#MEMORY_XD3D = 64
++MEMORY_XD3D = 64
++
++#
++# Fortran compiler
++#
++COMPILF = $(FC)
++
++#
++# C compiler
++#
++COMPILC = $(CC)
++RANLIB = ranlib
++AR = ar r
++STRIP = echo $@
++
++#
++# Options for the Fortran compiler
++#
++OPTF = $(FFLAGS)
++#
++# Options for the C compiler
++#
++OPTC = $(CFLAGS)
++
++#-----------------------------------------------
++# You should not need to change anything below !
++#-----------------------------------------------
++
++SRCDIR = $(XD3D_DIR)/src
++BINDIR = $(XD3D_DIR)/bin
++LIBDIR = $(XD3D_DIR)/lib
++SUFF =
++INCF = -I$(XD3D_DIR)/src/include
++INCC = -I$(LIBX11)/../include
++
++LINK = $(COMPILF) $(LDFLAGS) -o
++LINKOPT = -lc -lm
++LINKOPTX = -L$(LIBX11) -lX11 -lXpm -lc -lm
++LIBRAIRIE = $(LIBDIR)/question_lib.a
++MYXLIB = $(LIBDIR)/my_Xlib.a
++INTERP = $(LIBDIR)/interp.a
++
++.f.o: ; $(COMPILF) $(INCF) $(OPTF) -c $*.f
++.c.o: ; $(COMPILC) $(INCC) $(OPTC) -D$(LANGUAGE) -c $*.c
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
new file mode 100644
index 000000000000..8161fda3d9a7
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
@@ -0,0 +1,61 @@
+--- ./src/various/Makefile.orig 2009-12-04 18:16:57.000000000 +0000
++++ ./src/various/Makefile 2009-12-04 18:17:13.000000000 +0000
+@@ -1,6 +1,6 @@
+ include ../../RULES
+
+-all :; make clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
++all : clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
+
+ clair : clair.f $(LIBRAIRIE) ;\
+ $(LINK) $(BINDIR)/clair $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
+--- ./src/X/Makefile.orig 2009-12-04 18:16:06.000000000 +0000
++++ ./src/X/Makefile 2009-12-04 18:16:36.000000000 +0000
+@@ -118,7 +118,7 @@
+ lib : $(LIBMARC)
+ $(LIBMARC) : $(OBJETS) $(OBJETSMARC) ; $(AR) $@ $(OBJETS) $(OBJETSMARC) ; $(RANLIB) $@
+
+-all :; make ; make lib
++all : lib
+
+ clean : ; /bin/rm -f $(OBJETS) $(LIB) $(LIBMARC)
+
+--- ./Makefile.orig 2009-12-04 18:12:08.000000000 +0000
++++ ./Makefile 2009-12-04 19:06:37.000000000 +0000
+@@ -13,22 +13,24 @@
+ $(BINDIR)/xd3d$(SUFF) \
+ $(BINDIR)/xgraphic$(SUFF)
+
+-all :; make libs ; make utils ; make xgraphic ; make xd3d
++all : libs utils xgraphic xd3d
+
+ install :; /bin/cp -pidvu $(EXE) ./infps $(INSTALL_DIR)
+
+ libs :; \
+-cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; make ;\
+-cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ; make ;\
+-cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; make
+-
+-xd3d :; cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; make
+-
+-xgraphic :; cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; make
+-
+-utils :; \
+-echo " ---- Building various utils ----" ;\
+-cd $(SRCDIR)/trad_nopo ; make ;\
+-cd $(SRCDIR)/various ; make
++cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; $(MAKE) ;\
++cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ;$(MAKE) ;\
++cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; $(MAKE)
++
++xd3d : libs
++ cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; $(MAKE)
++
++xgraphic : libs
++ cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; $(MAKE)
++
++utils : libs
++ echo " ---- Building various utils ----" ;\
++ cd $(SRCDIR)/trad_nopo ; $(MAKE) ;\
++ cd $(SRCDIR)/various ; $(MAKE)
+
+ clean :; /bin/rm -f $(SRCDIR)/*/*.o $(LIBRAIRIE) $(MYXLIB) $(INTERP) $(EXE)
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
new file mode 100644
index 000000000000..9e66dcab586c
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
@@ -0,0 +1,10 @@
+--- src/X/rotated.c.orig 2009-12-04 18:09:55.000000000 +0000
++++ src/X/rotated.c 2009-12-04 18:10:37.000000000 +0000
+@@ -29,6 +29,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
++#include <stdlib.h>
+ #include "rotated.h"
+
+
diff --git a/sci-visualization/xd3d/metadata.xml b/sci-visualization/xd3d/metadata.xml
new file mode 100644
index 000000000000..31da504e2cc6
--- /dev/null
+++ b/sci-visualization/xd3d/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ xd3d is a simple scientific visualization tool designed to be easy to learn.
+ It can plot 2d and 3d meshes, with shadowing, contour plots, vector fields,
+ iso-contour (3d), as well as 3d surfaces z=f(x,y) defined by an algebraic
+ expression or a cloud of points. It generates high quality vector PostScript
+ files for scientific publications and still or animated bitmap images.
+ It includes the graph plotter xgraphic.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/xd3d/xd3d-8.3.1.ebuild b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
new file mode 100644
index 000000000000..124c85430504
--- /dev/null
+++ b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="Scientific visualization tool"
+HOMEPAGE="http://www.cmap.polytechnique.fr/~jouve/xd3d/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-rotated.patch \
+ "${FILESDIR}"/${P}-cflags.patch
+ sed \
+ -e 's:"zutil.h":<zlib.h>:g' \
+ -i src/qlib/timestuff.c || die
+}
+
+src_configure() {
+ tc-export CC
+ sed \
+ -e "s:##D##:${ED}:" \
+ -e "s:##lib##:$(get_libdir):" \
+ -i RULES.gentoo \
+ || die "failed to set up RULES.gentoo"
+ ./configure -arch=gentoo || die "configure failed."
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install
+
+ dodoc BUGS CHANGELOG FAQ FORMATS README
+ insinto /usr/share/doc/${PF}
+ doins Manuals/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r Examples
+ fi
+}