summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-14 19:12:39 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 11:12:43 +0100
commit1cc312eab8232570989affd5f49ca8fe24aff4f1 (patch)
treeceab84f6287d9b1a346936ba8a1cc2c984f2fac4 /sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild
parentsci-visualization/xgraph: Removing EAPI 4 ebuilds (diff)
downloadgentoo-1cc312eab8232570989affd5f49ca8fe24aff4f1.tar.gz
gentoo-1cc312eab8232570989affd5f49ca8fe24aff4f1.tar.bz2
gentoo-1cc312eab8232570989affd5f49ca8fe24aff4f1.zip
sci-visualization/xyscan: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3476
Diffstat (limited to 'sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild')
-rw-r--r--sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild b/sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..4a1f4c525d77
--- /dev/null
+++ b/sci-visualization/xyscan/xyscan-3.3.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils versionator
+
+MY_PV=$(replace_version_separator 2 '')
+
+DESCRIPTION="Tool for extracting data points from graphs"
+HOMEPAGE="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
+SRC_URI="http://star.physics.yale.edu/~ullrich/${PN}DistributionPage/${MY_PV}/${PN}-${MY_PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="l10n_fr"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:qApp->applicationDirPath() + \"/../docs\":\"${EPREFIX}/usr/share/doc/${PF}/html\":" \
+ xyscanWindow.cpp || die "Failed to fix docs path"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dobin xyscan
+ HTML_DOCS=( docs/en/. )
+ einstalldocs
+ use l10n_fr && dodoc -r docs/fr
+ newicon images/xyscanIcon.png xyscan.png
+ make_desktop_entry xyscan "xyscan data point extractor"
+}