summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-30 23:01:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-06 20:30:13 +0100
commit1a181c4f6c61cb3bc1c11fa700add911613d2bd8 (patch)
tree4f52337a6ae4f689a2d089d8575e1526b7b95145 /sci-visualization
parentsci-libs/lapack-reference: fix installation on Prefix, bug #608266 (diff)
downloadgentoo-1a181c4f6c61cb3bc1c11fa700add911613d2bd8.tar.gz
gentoo-1a181c4f6c61cb3bc1c11fa700add911613d2bd8.tar.bz2
gentoo-1a181c4f6c61cb3bc1c11fa700add911613d2bd8.zip
sci-visualization/spyview: Fix 20150124 ebuild
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3731
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spyview/files/spyview-20150124-gnuplot_interface_fix.patch10
-rw-r--r--sci-visualization/spyview/spyview-20150124.ebuild19
2 files changed, 20 insertions, 9 deletions
diff --git a/sci-visualization/spyview/files/spyview-20150124-gnuplot_interface_fix.patch b/sci-visualization/spyview/files/spyview-20150124-gnuplot_interface_fix.patch
new file mode 100644
index 000000000000..6f15296012f2
--- /dev/null
+++ b/sci-visualization/spyview/files/spyview-20150124-gnuplot_interface_fix.patch
@@ -0,0 +1,10 @@
+--- a/spyview/Gnuplot_Interface.C
++++ b/spyview/Gnuplot_Interface.C
+@@ -13,6 +13,7 @@
+ #else
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/wait.h>
+ #endif
+ using namespace boost;
+
diff --git a/sci-visualization/spyview/spyview-20150124.ebuild b/sci-visualization/spyview/spyview-20150124.ebuild
index fd110c3518eb..212779375b23 100644
--- a/sci-visualization/spyview/spyview-20150124.ebuild
+++ b/sci-visualization/spyview/spyview-20150124.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit autotools flag-o-matic eutils multilib
+inherit autotools flag-o-matic
DESCRIPTION="2D and 3D data visualization and analysis program"
HOMEPAGE="http://nsweb.tn.tudelft.nl/~gsteele/spyview/"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/gsteele13/spyview/archive/966012afae2fbb77262bd96a7e
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="" # no keywords since it doesnt build yet...
+KEYWORDS="~amd64 ~x86"
IUSE=""
COMMON_DEPEND="
@@ -29,6 +29,8 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
sci-visualization/gnuplot"
+PATCHES=( ${FILESDIR}/${P}-gnuplot_interface_fix.patch )
+
src_unpack() {
default
mv -v "${WORKDIR}"/spyview-*/source "${S}" || die
@@ -36,18 +38,17 @@ src_unpack() {
src_prepare() {
append-cflags $(fltk-config --cflags)
- append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+ append-cxxflags $(fltk-config --cxxflags)
+ append-cppflags -I"${EPREFIX}"/usr/include/netpbm
# append-ldflags $(fltk-config --ldflags)
# this one leads to an insane amount of warnings
append-ldflags -L$(dirname $(fltk-config --libs))
- find "${S}" -name Makefile.am -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
+ while IFS="" read -d $'\0' -r file; do
+ sed -i -e 's:-mwindows -mconsole::g' "$file" || die
+ done < <(find "${S}" -name Makefile.am -print0)
default
eautoreconf
}
-
-src_configure() {
- econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
-}