summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwangjiezhe <wangjiezhe@gmail.com>2024-01-19 20:59:34 +0800
committerJason Zaman <perfinion@gentoo.org>2024-02-03 11:32:48 -0800
commitbeef914babe36ac00193e9a0263a584a4bf467db (patch)
treeca2b95959b47cb3c5bb74c55dd835a545d201b0e /sci-visualization
parentdev-python/protobuf-python: add 4.22.5 (diff)
downloadgentoo-beef914babe36ac00193e9a0263a584a4bf467db.tar.gz
gentoo-beef914babe36ac00193e9a0263a584a4bf467db.tar.bz2
gentoo-beef914babe36ac00193e9a0263a584a4bf467db.zip
sci-visualization/tensorboard: add 2.13.0
Signed-off-by: wangjiezhe <wangjiezhe@gmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.13.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 520d06a75624..e775562064f5 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,3 +1,4 @@
DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
DIST tensorboard-2.11.0-py3-none-any.whl.zip 5990351 BLAKE2B d6796fceb047abc69c84c8f30ce6b5e0739a376e110fb7e2bb78ee5b6c7dd8d1344546950d46dbdc3a47780f4ad685be186087286225dbeb9ebce558f0837d8c SHA512 f1b908e13a56a86f6618ae8bf596339243642d0f00793d326ac884fd8e736bb316331728b474022936570fb6202b323d8ba2bf4908619aa1f79411b904edf209
DIST tensorboard-2.12.0-py3-none-any.whl.zip 5638388 BLAKE2B 617c76fa49b2aa647d7f099d8dbc7d53449e3024981f2f5858c1eff44b6a3c9369169579436562373fd2f44222e506b54d10083292352b70c400f16dcfaf1dec SHA512 d7eaeeb68adf1ad121bffd15f5147564af78ee74b7f2f251f6111bc94973b4ee7c952de51eab4608126a230b4709af5c67944608f4c5c73918af82945abc63e3
+DIST tensorboard-2.13.0-py3-none-any.whl.zip 5569681 BLAKE2B f7c671e9a59ab50c9bf150d52826a70091908876ebd65ee39e347eef15f63d1c1e3dadd6c2748917bdd640a09e1816238b755de92c2eb82ca296a67a28be0387 SHA512 6d934632855431056a4b255be52312a9cb6592ca4fde97a2a563634dbbc7ff2809cac6adbffbd6ea5eb03f22cdf682593b704704ed9af208cea9a36030cd9ff1
diff --git a/sci-visualization/tensorboard/tensorboard-2.13.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.13.0.ebuild
new file mode 100644
index 000000000000..1983d32cdb5b
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.13.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit python-r1 pypi
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="$(pypi_wheel_url --unpack)"
+S=${WORKDIR}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+ ${PYTHON_DEPS}
+"
+PDEPEND="
+ =sci-libs/tensorflow-2.13*[python,${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+ sed -i -e 's/protobuf.*$/protobuf/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax protobuf deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}