summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 23:14:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-18 23:32:34 +0100
commit88e9a7c687b351e915d227fa6a5bc8fcbbc38712 (patch)
tree587a6481eda0820c91f7468cccd14e78ced60fb8 /sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild
parentMove {app-crypt → sec-keys}/openpgp-keys-bcl (diff)
downloadgentoo-88e9a7c687b351e915d227fa6a5bc8fcbbc38712.tar.gz
gentoo-88e9a7c687b351e915d227fa6a5bc8fcbbc38712.tar.bz2
gentoo-88e9a7c687b351e915d227fa6a5bc8fcbbc38712.zip
Move {app-crypt → sec-keys}/openpgp-keys-botan
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild')
-rw-r--r--sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild b/sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild
new file mode 100644
index 000000000000..464b1013e383
--- /dev/null
+++ b/sec-keys/openpgp-keys-botan/openpgp-keys-botan-20210416.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used to sign Botan releases"
+HOMEPAGE="https://botan.randombit.net https://botan.randombit.net/pgpkey.txt"
+SRC_URI="https://botan.randombit.net/pgpkey.txt -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
+
+src_install() {
+ local files=( ${A} )
+
+ insinto /usr/share/openpgp-keys
+ newins - botan.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}