summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-01 23:10:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-01 23:12:34 +0100
commit42ca93213d270a188cd7e9555d2cd677a6de62db (patch)
tree1e2bd9c15b804714b35d714f683815354f8bf556 /sec-keys/openpgp-keys-gentoo-auth
parentx11-base/xorg-server: fix suid for installations without logind provider. (diff)
downloadgentoo-42ca93213d270a188cd7e9555d2cd677a6de62db.tar.gz
gentoo-42ca93213d270a188cd7e9555d2cd677a6de62db.tar.bz2
gentoo-42ca93213d270a188cd7e9555d2cd677a6de62db.zip
sec-keys/openpgp-keys-gentoo-auth: Bump to 20220101
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sec-keys/openpgp-keys-gentoo-auth')
-rw-r--r--sec-keys/openpgp-keys-gentoo-auth/Manifest1
-rw-r--r--sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20220101.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-gentoo-auth/Manifest b/sec-keys/openpgp-keys-gentoo-auth/Manifest
index 928b9645b900..a483267fe47d 100644
--- a/sec-keys/openpgp-keys-gentoo-auth/Manifest
+++ b/sec-keys/openpgp-keys-gentoo-auth/Manifest
@@ -1 +1,2 @@
DIST gentoo-auth.asc.20200704.gz 4540 BLAKE2B 8ae8a1947ae81e89aef6171b228e97a80331cc58336a0387bbda7c885ec5fff322d17b7fc462d7f3fe88a965455b94d1e16b705903843d75fa53481d525a1965 SHA512 da7d1aa76ea04f465e690560dd2d09306aa120b9f2771abc6fe06d5181c39c9e7db73ae0b9c01b864ccdd55a881a7e9c9716dd87446c809b901bb17c448878f5
+DIST gentoo-auth.asc.20220101.gz 5775 BLAKE2B fd8caa753da59bcb9597e302d2c94e6053c5977dbda19d04a7f2a404c6880328c1cdec4251ed44f0f9e9471d2f66e7ff06ea61151770122e95ea9ba6df7e2c85 SHA512 162f5ca1a8c081f889697885c6e261e61bc7ee3dba04418169f85d8161b02866474f0ae95e72e47d83fb10b1ba3eb18d5a0d8556fcf70d094a248c4958f5f9a0
diff --git a/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20220101.ebuild b/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20220101.ebuild
new file mode 100644
index 000000000000..87701af5f187
--- /dev/null
+++ b/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20220101.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo Authority Keys (GLEP 79)"
+HOMEPAGE="https://www.gentoo.org/downloads/signatures/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/openpgp-keys/gentoo-auth.asc.${PV}.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+S=${WORKDIR}
+
+# Keys included:
+# ABD00913019D6354BA1D9A132839FE0D796198B1
+# 18F703D702B1B9591373148C55D3238EC050396E
+# 2C13823B8237310FA213034930D132FF0FF50EEB
+
+src_install() {
+ insinto /usr/share/openpgp-keys
+ newins "gentoo-auth.asc.${PV}" gentoo-auth.asc
+ newins - gentoo-auth-ownertrust.txt <<-EOF
+ ABD00913019D6354BA1D9A132839FE0D796198B1:6:
+ EOF
+}