summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2020-11-24 19:46:32 +0100
committerMichael Palimaka <kensington@gentoo.org>2020-11-25 18:29:39 +1100
commit3aea4d8765e72c99d0338af185ea3bd168fc66c5 (patch)
treeafeea5e18ee2282ed3659dd25b058fa415071065 /sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild
parentapp-text/ansifilter: remove 2.16 (diff)
downloadgentoo-3aea4d8765e72c99d0338af185ea3bd168fc66c5.tar.gz
gentoo-3aea4d8765e72c99d0338af185ea3bd168fc66c5.tar.bz2
gentoo-3aea4d8765e72c99d0338af185ea3bd168fc66c5.zip
sec-policy/apparmor-profiles[minimal]: install abi folder
Closes: https://bugs.gentoo.org/756364 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild')
-rw-r--r--sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild b/sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..e03119a08670
--- /dev/null
+++ b/sec-policy/apparmor-profiles/apparmor-profiles-3.0.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="$(ver_cut 1-2)"
+
+DESCRIPTION="A collection of profiles for the AppArmor application security system"
+HOMEPAGE="https://gitlab.com/apparmor/apparmor/wikis/home"
+SRC_URI="https://launchpad.net/apparmor/${MY_PV}/${MY_PV}/+download/apparmor-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal"
+
+RESTRICT="test"
+
+S=${WORKDIR}/apparmor-${PV}/profiles
+
+src_install() {
+ if use minimal ; then
+ insinto /etc/apparmor.d
+ doins -r apparmor.d/{abi,abstractions,tunables}
+ else
+ default
+ fi
+}