summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-01 12:34:51 -0800
committerMatt Turner <mattst88@gentoo.org>2022-03-01 12:37:19 -0800
commit63ce5e4655a44d2ee0aed9579e42022045cfe00a (patch)
treea68f46242f68fc7e264fc602c102fd499a75350f /sys-apps/accountsservice
parentdev-vcs/git-big-picture: 1.2.0 (diff)
downloadgentoo-63ce5e4655a44d2ee0aed9579e42022045cfe00a.tar.gz
gentoo-63ce5e4655a44d2ee0aed9579e42022045cfe00a.tar.bz2
gentoo-63ce5e4655a44d2ee0aed9579e42022045cfe00a.zip
sys-apps/accountsservice: Version bump to 22.08.8
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/accountsservice')
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-22.08.8.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index 479f3c1a85a3..91141c539c0c 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1,3 +1,4 @@
DIST accountsservice-0.6.55.tar.xz 97972 BLAKE2B aba3adfeb53e64455ce8e672b9db754bae4af6b4de0823cc021d0311a381ec40af04371e78f7c84eab7fb72356b26e22db78aad0343d57f65ea71a7742b51fc7 SHA512 c12e6a8e80f9b087f97238da4734d2d3a14a7c5cbd870a32a04b00116f176c818c39fb886f6dc72c3e93c136b0c2074ddf8f77e20431fa3bd54f138bea9d262d
DIST accountsservice-22.04.62.tar.xz 101740 BLAKE2B b0514e2160560816fa64688072c0534ad6375ef699459e24a083f738fe8388c2f13b2ea37acbb50c64b9823fc5391356deddfd964e22d9db722bfe6816009cb8 SHA512 4d37b09c1cb1b55dc474cb76c53cbf0a3172bb0e6a0782405c0c09b9680ee3ac02103dfd57777bf131649de2ad0ebc8063362fa7ca18edfd2cb6d2a38a886900
DIST accountsservice-22.07.5.tar.xz 101688 BLAKE2B db8e5001f0b81b89c105d15557d5c62251ca58e4fad08f3cbfd52881b05980ccbb693766347c5cde640dcf3823a59f667fe15ec0c8e04cdd226915f91cea90a6 SHA512 9099abc9d8db58672db01e6ba9b23ba7bc8ed910ac001499d2a241089f55eafac47a482811cba80b1d6ee11df03a384e8ef2fd87df3b1125a8cf97c580177534
+DIST accountsservice-22.08.8.tar.xz 102672 BLAKE2B 7c9436d3845fc1883772b434c4f9e2fba934d17e6d4452a6be65e1d790a23b331eaaa64b0e6eff6fefe79587a40cf1749a0f3de09f323b10740046bd9d145c9d SHA512 2ca3ceb1b44338d9924b86788256d4eef7ec10e0c2197bfb8cc6c31ae224fab3051f03cb406a526f90057684965bef4ba0f2cc01b26198ec1fc6baec36ad3ff8
diff --git a/sys-apps/accountsservice/accountsservice-22.08.8.ebuild b/sys-apps/accountsservice/accountsservice-22.08.8.ebuild
new file mode 100644
index 000000000000..cc2ca7bb4783
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-22.08.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="doc elogind gtk-doc +introspection selinux systemd test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="^^ ( elogind systemd )"
+
+CDEPEND="
+ >=dev-libs/glib-2.63.5:2
+ sys-auth/polkit
+ virtual/libcrypt:=
+ elogind? ( >=sys-auth/elogind-229.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ systemd? ( >=sys-apps/systemd-186:0= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-accountsd )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.04.62-gentoo-system-users.patch
+)
+
+python_check_deps() {
+ if use test; then
+ has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ --localstatedir="${EPREFIX}/var"
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dadmin_group="wheel"
+ $(meson_use elogind)
+ $(meson_use introspection)
+ $(meson_use doc docbook)
+ $(meson_use gtk-doc gtk_doc)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # https://gitlab.freedesktop.org/accountsservice/accountsservice/-/issues/90
+ if use doc; then
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${PF}" || die
+ fi
+
+ # This directories are created at runtime when needed
+ rm -r "${ED}"/var/lib || die
+}