summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-23 06:51:00 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-23 06:51:05 -0400
commit2f0e7d25118845594d6ed87f8e5f257631ea7aab (patch)
treec99fa94c453815f356cb284dacf372f38ab7415b /sys-apps/ack/ack-3.0.0.ebuild
parentsys-auth/pambase: change homepage to github (diff)
downloadgentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.tar.gz
gentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.tar.bz2
gentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.zip
sys-apps/ack: Bump to 3.0.0
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'sys-apps/ack/ack-3.0.0.ebuild')
-rw-r--r--sys-apps/ack/ack-3.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/ack/ack-3.0.0.ebuild b/sys-apps/ack/ack-3.0.0.ebuild
new file mode 100644
index 000000000000..28e686602b8c
--- /dev/null
+++ b/sys-apps/ack/ack-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=PETDANCE
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="ack is a tool like grep, optimized for programmers"
+HOMEPAGE="https://beyondgrep.com"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-perl/File-Next-1.160.0"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/IO-Tty )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.0-gentoo.patch )
+
+src_test() {
+ # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
+ # which enables interactive tests that need to read from stdin. If IO-Tty
+ # is not installed the related tests are skipped.
+ MAKEOPTS+=" -j1" perl-module_src_test
+}