summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-04-02 18:17:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-04-02 18:17:56 -0400
commit0b5da2633a263dbc95d7d2d1e69d7c22f35950c4 (patch)
tree853333313a1a8e72b7ba0c85bf09c89d02830b9a /sys-apps/agedu/agedu-20180329.ebuild
parentapp-backup/borgbackup: version bump to 1.1.5 (diff)
downloadgentoo-0b5da2633a263dbc95d7d2d1e69d7c22f35950c4.tar.gz
gentoo-0b5da2633a263dbc95d7d2d1e69d7c22f35950c4.tar.bz2
gentoo-0b5da2633a263dbc95d7d2d1e69d7c22f35950c4.zip
sys-apps/agedu: version bump to 20180329
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/agedu/agedu-20180329.ebuild')
-rw-r--r--sys-apps/agedu/agedu-20180329.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/agedu/agedu-20180329.ebuild b/sys-apps/agedu/agedu-20180329.ebuild
new file mode 100644
index 000000000000..72f7d0242506
--- /dev/null
+++ b/sys-apps/agedu/agedu-20180329.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools eutils
+
+# agedu-20151213.59b0ed3.ebuild is not a legitimate name
+# so we'll drop versionator and just set MY_P manually.
+MY_P="${PN}"-20180329.af641e6
+
+DESCRIPTION="A utility for tracking down wasted disk space"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/agedu/"
+SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/agedu/${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6"
+
+DEPEND="doc? ( app-doc/halibut )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv4 \
+ $(use_enable doc halibut) \
+ $(use_enable ipv6)
+}