summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-05-22 03:41:16 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-05-22 03:41:16 -0400
commit4097789c484f59c78cbfea7e9b296758f12111b4 (patch)
tree35cfe82bf5723461dcca05f1e3a6321f81e553b7 /sys-apps/agedu/agedu-20180522.ebuild
parentnet-dns/bind: Version, bug 656038, CVE-2018-5736 / CVE-2018-5737 (diff)
downloadgentoo-4097789c484f59c78cbfea7e9b296758f12111b4.tar.gz
gentoo-4097789c484f59c78cbfea7e9b296758f12111b4.tar.bz2
gentoo-4097789c484f59c78cbfea7e9b296758f12111b4.zip
sys-apps/agedu: version bump to 20180522
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/agedu/agedu-20180522.ebuild')
-rw-r--r--sys-apps/agedu/agedu-20180522.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/agedu/agedu-20180522.ebuild b/sys-apps/agedu/agedu-20180522.ebuild
new file mode 100644
index 000000000000..bf79051e2ba8
--- /dev/null
+++ b/sys-apps/agedu/agedu-20180522.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+# agedu-20151213.59b0ed3.ebuild is not a legitimate name
+# so we'll drop versionator and just set MY_P manually.
+MY_P="${PN}"-20180522.5b12791
+
+DESCRIPTION="A utility for tracking down wasted disk space"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/agedu/"
+SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/agedu/${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6"
+
+DEPEND="doc? ( app-doc/halibut )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv4 \
+ $(use_enable doc halibut) \
+ $(use_enable ipv6)
+}