summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/agedu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/agedu/files')
-rw-r--r--sys-apps/agedu/files/agedu-r9671-fix-automagic.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
new file mode 100644
index 000000000000..8e0c6ea2969e
--- /dev/null
+++ b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
@@ -0,0 +1,44 @@
+diff -Naur agedu-r9671.orig/configure.ac agedu-r9671/configure.ac
+--- agedu-r9671.orig/configure.ac 2012-10-20 21:20:47.000000000 -0400
++++ agedu-r9671/configure.ac 2012-10-21 15:13:08.000000000 -0400
+@@ -10,8 +10,6 @@
+ AC_PROG_CC
+ AC_PROG_CC_C99
+ AC_PROG_INSTALL
+-AC_CHECK_PROG([HALIBUT],[halibut],[yes],[no])
+-AM_CONDITIONAL([HAVE_HALIBUT],[test "x$HALIBUT" = "xyes"])
+
+ # Checks for libraries.
+
+@@ -43,13 +41,28 @@
+
+ AC_CHECK_FUNCS([ftruncate fdopendir lstat64 stat64 memchr munmap select socket strcasecmp strchr strcspn strerror strrchr strspn strtoul strtoull connect inet_ntoa inet_addr gethostbyname getaddrinfo])
+
++AC_ARG_ENABLE([halibut],
++ AS_HELP_STRING([--disable-halibut],
++ [disable documentation with halibut (default off)]),
++ [halibut=$enableval],[halibut=no])
++
++if test "$halibut" = "no"; then
++ AM_CONDITIONAL([HAVE_HALIBUT],[false])
++else
++ AC_CHECK_PROG([have_halibut],[halibut],[yes],[no])
++ if test "$have_halibut" = "no"; then
++ AC_MSG_ERROR([halibut configured but not found])
++ fi
++ AM_CONDITIONAL([HAVE_HALIBUT],[true])
++fi
++
+ AC_ARG_ENABLE([ipv6],
+ AS_HELP_STRING([--disable-ipv6],
+- [disable IPv6 in the built-in web server]),
+- [ipv6=$enableval],[ipv6=$ac_cv_func_getaddrinfo])
++ [disable IPv6 in the built-in web server (default off)]),
++ [ipv6=$enableval],[ipv6=no])
+ AC_ARG_ENABLE([ipv4],
+ AS_HELP_STRING([--disable-ipv4],
+- [disable IPv4 in the built-in web server]),
++ [disable IPv4 in the built-in web server (default on)]),
+ [ipv4=$enableval],[ipv4=yes])
+ if test "$ipv6" = "no"; then
+ AC_DEFINE([NO_IPV6], [1], [define if IPv6 is disabled at configure time])