summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-28 18:10:05 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-28 18:10:05 -0600
commit1b48c31a457d9d0fd39425e30ec1965e1b2923dd (patch)
tree436319468afca840663f9d9b50247103216b7af1 /sys-apps/baselayout
parentsys-apps/baselayout: handle /etc/gentoo-release with CONFIG_PROTECT_MASK (diff)
downloadgentoo-1b48c31a457d9d0fd39425e30ec1965e1b2923dd.tar.gz
gentoo-1b48c31a457d9d0fd39425e30ec1965e1b2923dd.tar.bz2
gentoo-1b48c31a457d9d0fd39425e30ec1965e1b2923dd.zip
sys-apps/baselayout: sync live
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild11
1 files changed, 0 insertions, 11 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index afc0043d403a..64d8126ed757 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -192,11 +192,6 @@ multilib_layout() {
}
pkg_preinst() {
- # This is written in src_install (so it's in CONTENTS), but punt all
- # pending updates to avoid user having to do etc-update (and make the
- # pkg_postinst logic simpler).
- rm -f "${EROOT}"/etc/._cfg????_gentoo-release || die
-
# We need to install directories and maybe some dev nodes when building
# stages, but they cannot be in CONTENTS.
# Also, we cannot reference $S as binpkg will break so we do this.
@@ -316,12 +311,6 @@ pkg_postinst() {
chmod o-rwx "${EROOT}/etc/${x}" || die
fi
done
-
- # Take care of the etc-update for the user
- if [ -e "${EROOT}"/etc/._cfg0000_gentoo-release ] ; then
- mv "${EROOT}"/etc/._cfg0000_gentoo-release "${EROOT}"/etc/gentoo-release || die
- fi
-
# whine about users that lack passwords #193541
if [[ -e "${EROOT}"/etc/shadow ]] ; then
local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${EROOT}"/etc/shadow)