summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-04 00:20:48 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-04 00:20:48 -0600
commit49a7344fcfa1b0b75e02afe61fe807771ac71702 (patch)
tree0451b57839cf11cf4a1ccb79069c4d19c481305c /sys-apps/baselayout
parentapp-office/gnucash: Stabilize 4.12-r1 amd64, #888469 (diff)
downloadgentoo-49a7344fcfa1b0b75e02afe61fe807771ac71702.tar.gz
gentoo-49a7344fcfa1b0b75e02afe61fe807771ac71702.tar.bz2
gentoo-49a7344fcfa1b0b75e02afe61fe807771ac71702.zip
sys-apps/baselayout: remove bsd specific code
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index b7fc36bdb833..6a97e21522d9 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -163,18 +163,13 @@ multilib_layout() {
# make sure the old "lib" ABI location does not exist; we
# only symlinked the lib dir on systems where we moved it
# to "lib32" ...
- case ${CHOST} in
- *-gentoo-freebsd*) ;; # We want it the other way on fbsd.
- i?86*|x86_64*|powerpc*|sparc*|s390*)
- if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
- rm -f "${prefix}lib32"/.keep || die
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
- fi
+ if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
+ rm -f "${prefix}lib32"/.keep || die
+ if ! rmdir "${prefix}lib32" 2>/dev/null ; then
+ ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
+ die "non-empty dir found where there should be none: ${prefix}lib32"
fi
- ;;
- esac
+ fi
else
# nothing exists, so just set it up sanely
ewarn "Initializing ${prefix}lib as a dir"
@@ -257,7 +252,6 @@ src_prepare() {
src_install() {
emake \
- OS=Linux \
DESTDIR="${ED}" \
install