summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2016-06-11 13:05:18 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-11 19:52:08 +0000
commit05bbcafaf6b7aa3adcbe08e526d798ca7b759387 (patch)
tree144270930da133b27ff11469b80e93d0e4509023 /sys-apps/bleachbit/bleachbit-1.11.2.ebuild
parentsys-kernel/rt-sources: version bump to 4.6.2_p5 and remove old (diff)
downloadgentoo-05bbcafaf6b7aa3adcbe08e526d798ca7b759387.tar.gz
gentoo-05bbcafaf6b7aa3adcbe08e526d798ca7b759387.tar.bz2
gentoo-05bbcafaf6b7aa3adcbe08e526d798ca7b759387.zip
sys-apps/bleachbit: version bump to 1.11.2
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1648 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-apps/bleachbit/bleachbit-1.11.2.ebuild')
-rw-r--r--sys-apps/bleachbit/bleachbit-1.11.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/bleachbit-1.11.2.ebuild b/sys-apps/bleachbit/bleachbit-1.11.2.ebuild
new file mode 100644
index 000000000000..1f93d1437beb
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-1.11.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="ar ast be bg bn bs ca cs da de el en_AU en_CA en_GB eo es et eu fa fi fo fr gl he hi hr hu hy ia id it ja ko ku ky lt lv
+ms my nb nds nl nn pl pt_BR pt ro ru se si sk sl sr sv ta te th tr ug uk uz vi zh_CN zh_TW"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils l10n
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk nls"
+
+RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( README.md )
+
+python_prepare_all() {
+ rem_locale() {
+ rm "po/${1}.po" || die "removing of ${1}.po failed"
+ }
+
+ l10n_find_plocales_changes po "" ".po"
+ l10n_for_each_disabled_locale_do rem_locale
+
+ # choose correct Python implementation, bug #465254
+ sed -i -e 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use nls && emake -C po
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # https://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+ python_replicate_script "${D}/usr/bin/${PN}"
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}