summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2019-12-03 21:07:04 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-03 19:41:05 -0500
commite40409cc94e11f6e396f4dcc4f2be0ae3c9ee683 (patch)
tree919ba5aeff8c08530cb8e452547abd03cb891008 /sys-apps/bleachbit/bleachbit-2.2.ebuild
parentprofiles/package.mask: unmask several packages I am maintaining (diff)
downloadgentoo-e40409cc94e11f6e396f4dcc4f2be0ae3c9ee683.tar.gz
gentoo-e40409cc94e11f6e396f4dcc4f2be0ae3c9ee683.tar.bz2
gentoo-e40409cc94e11f6e396f4dcc4f2be0ae3c9ee683.zip
sys-apps/bleachbit: Remove old
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/13852 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sys-apps/bleachbit/bleachbit-2.2.ebuild')
-rw-r--r--sys-apps/bleachbit/bleachbit-2.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/bleachbit/bleachbit-2.2.ebuild b/sys-apps/bleachbit/bleachbit-2.2.ebuild
deleted file mode 100644
index 79c60771348a..000000000000
--- a/sys-apps/bleachbit/bleachbit-2.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit desktop distutils-r1
-
-DESCRIPTION="Clean junk to free disk space and to maintain privacy"
-HOMEPAGE="https://www.bleachbit.org"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+gtk"
-
-RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
-BDEPEND="sys-devel/gettext"
-
-python_prepare_all() {
- # choose correct Python implementation, bug #465254
- sed -i 's/python/$(PYTHON)/g' po/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C po local
-}
-
-python_install() {
- distutils-r1_python_install
- python_newscript ${PN}.py ${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- emake -C po DESTDIR="${D}" install
-
- # https://bugs.gentoo.org/388999
- insinto /usr/share/bleachbit/cleaners
- doins cleaners/*.xml
-
- doicon ${PN}.png
- domenu ${PN}.desktop
-}
-
-pkg_postinst() {
- elog "Bleachbit has optional notification support. To enable, please install:"
- elog ""
- elog " dev-python/notify-python"
-}