summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2021-11-14 13:53:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-11-24 10:07:35 +0200
commit321e0e2881b447156d241387b0894d429b494c49 (patch)
treeeb0d2599c272def15c5949e238515df14caa044b /sys-apps/bleachbit
parentgui-apps/tuigreet: version bump to 0.7.1 (diff)
downloadgentoo-321e0e2881b447156d241387b0894d429b494c49.tar.gz
gentoo-321e0e2881b447156d241387b0894d429b494c49.tar.bz2
gentoo-321e0e2881b447156d241387b0894d429b494c49.zip
sys-apps/bleachbit: Bump to 4.4.2, EAPI=8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-4.4.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index aa82595ff5f5..35ec65996d64 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,2 +1,3 @@
DIST bleachbit-4.2.0.tar.bz2 606223 BLAKE2B c45a11db556b9c3e3a19583bfaa633244e2ea2e374ec8b883cba486126cfb33617cd7930af79d379711980ad4b56426b39a3e68532462be1918da1386369d137 SHA512 6d43da42c6a2a328c8fb766a3f00f4511e72a00836316c279c8dc3a24468abb4c2ce909b42c568ee0b8417c08827c7cb79ae197ae693b8d6ce60faf22422effb
DIST bleachbit-4.4.0.tar.bz2 640690 BLAKE2B 577b5498eeb25c499753468fd6d20fa398423ee0f36837069ecd3c6e32d20686bdf2e41492d8b082551ad373266f98963d900bc68042dc0715a5f509945be352 SHA512 ad117a790803dc405752a4582b735351842305603de7ea9d98b0d59d93e8f75e18d7125958c1cb907891098f79502ebe5a560191384036506ac4ea66694f93af
+DIST bleachbit-4.4.2.tar.bz2 653525 BLAKE2B ae65e310d33c2e523244a32de1ff28081be940a6a2ed2aadf682218ebe7346de3b5f37ab457d4f16542730d617678effbcda461e7080c43cd81c17f6b959018d SHA512 247a1ed0e491e5e02c4bc9a5c2d11d5f1511ef9644b9edf34b1c9326e6515c33dfd60b98bb2dab59eac36ab5e1c9b5ed1e8d7c749261bde90450a2fc717dae6f
diff --git a/sys-apps/bleachbit/bleachbit-4.4.2.ebuild b/sys-apps/bleachbit/bleachbit-4.4.2.ebuild
new file mode 100644
index 000000000000..6cca03a93f7c
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.4.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="sqlite(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
+ )
+"
+
+distutils_enable_tests unittest
+
+# tests fail under FEATURES=usersandbox
+RESTRICT="test"
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # only applicable to Windows installer
+ rm tests/TestNsisUtilities.py || die
+
+ # these fail on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_notify(self)/_&/" \
+ -i tests/TestGUI.py || die
+
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}