summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2017-12-28 17:18:40 +0100
committerCraig Andrews <candrews@gentoo.org>2017-12-29 14:54:30 -0500
commit6c76bd429e92f20a651e15c4b1d3ecb98f93e8bd (patch)
treee8142a41f50f14ec6a799e02c9589b78edd7bee7 /sys-apps/bleachbit
parentdev-perl/Alien-wxWidgets: Version bump (diff)
downloadgentoo-6c76bd429e92f20a651e15c4b1d3ecb98f93e8bd.tar.gz
gentoo-6c76bd429e92f20a651e15c4b1d3ecb98f93e8bd.tar.bz2
gentoo-6c76bd429e92f20a651e15c4b1d3ecb98f93e8bd.zip
sys-apps/bleachbit: Bump to 1.19.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-1.19.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index a02db1f71fd4..de67cfee1ac5 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,2 +1,3 @@
DIST bleachbit-1.12.tar.bz2 396838 BLAKE2B 1784b5bc6602e5599b29ffbd0ad0f27f05ffe3aaab25756e3e07fff56c72517493b551063975c943a0e16efc2ecb30fdf69878577b8a5b27eccfdfb3bdd59c40 SHA512 b9c13a75b86eebbedaf928394714ac4d7847b8d53d345a4884acee68cd9c46ff1d5f4108479d7695109bad03c0fcdbb6f89e77d8794a60697fd5c6acdb34530c
DIST bleachbit-1.17.tar.gz 867671 BLAKE2B aca71b2e552ff21aab3e86a4200096d5d22bd451111d38bd487dd6ca77aff862917c324ede679e7860cad3d6671aec900d16f8b08a5eb488780bfb18631efd7c SHA512 c1d7d266e7baef532a9826ce1a0fb8cd247136a335c3236ba7cf6e4f7af4420e4f0f424fb98579c5433ebd55138860657a3fad3ad56ed4f4a3f8163526a73e95
+DIST bleachbit-1.19.tar.gz 881530 BLAKE2B b3a9ebe066828ead728f4393ba9d52b92967004638f7d74a5dd0576693d2e7ee37eb9e4e4352b973602b7bd6179c7b3a5816109f3f57a56e95c5cbfde32472c3 SHA512 2543a121786ae41c535c7faaf9741808bca57bde75da9b7df75c2653e2864441713fe3b3388ff71db2e88dc9626b457c656fa713774899b7a4912d05329b7eb2
diff --git a/sys-apps/bleachbit/bleachbit-1.19.ebuild b/sys-apps/bleachbit/bleachbit-1.19.ebuild
new file mode 100644
index 000000000000..f6f51d048670
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-1.19.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="
+ ar ast be bg bn bs ca cs da de el en_AU en_CA en_GB eo es et eu fa fi fo fr
+ gl he hi hr hu hy ia id it ja ko ku ky lt lv ms my nb nds nl nn pl pt pt_BR
+ ro ru se si sk sl sq sr sv ta te th tr ug uk uz vi zh_CN zh_TW"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1 eutils l10n
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk nls"
+
+RDEPEND="
+ dev-python/notify-python[$PYTHON_USEDEP]
+ gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+python_prepare_all() {
+ rem_locale() {
+ rm "po/${1}.po" &>/dev/null
+ if [[ $? -ne 0 ]]; then
+ eerror "Removing of ${1}.po failed"
+ die
+ fi
+ }
+
+ l10n_find_plocales_changes po "" ".po"
+ l10n_for_each_disabled_locale_do rem_locale
+
+ # choose correct Python implementation, bug #465254
+ sed -i 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use nls && emake -C po
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # https://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+ python_replicate_script "${D}/usr/bin/${PN}"
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}