summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-22 13:42:19 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-22 14:30:25 -0400
commita974e34887092590c23c27cc4127bc5c29608edf (patch)
treeae53ef856f0c810be7457244ada0c8e356dfafe3 /sys-apps/bolt
parentdev-java/openjdk: fix openjdk17-riscv-patch manifest (diff)
downloadgentoo-a974e34887092590c23c27cc4127bc5c29608edf.tar.gz
gentoo-a974e34887092590c23c27cc4127bc5c29608edf.tar.bz2
gentoo-a974e34887092590c23c27cc4127bc5c29608edf.zip
sys-apps/bolt: Version bump to 0.9.2
* Bump to EAPI=8 * Inherit udev.eclass and call udev_reload (bug #851807) * Add subslot operator on virtual/libudev dependency * Drop unnecessary IUSE=systemd and dependence on systemd * Drop unused systemd.eclass inherit * Move dependence on dev-util/umockdev from RDEPEND to DEPEND, and only under test? ( ... ) * Move dev-util/glib-utils from DEPEND/RDEPEND to BDEPEND * Add virtual/pkgconfig to BDEPEND * Remove IUSE=doc and unconditionally build man pages * Move dependence on app-text/asciidoc from DEPEND/RDEPEND to BDEPEND * Add ${EPREFIX} to configured paths * Add GPL-2+ to LICENSE for 90-bolt.rules * Move CONFIG_ checks from pkg_pretend to pkg_setup, which has the additional benefit of executing them only once Closes: https://bugs.gentoo.org/836896 Closes: https://bugs.gentoo.org/851807 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/Manifest1
-rw-r--r--sys-apps/bolt/bolt-0.9.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 397f4cbf599e..96e5b97f9ed7 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1 +1,2 @@
DIST bolt-0.9.1.tar.gz 250978 BLAKE2B a3b1ea51704e2b54abb0135013019b9cad6ed9c0acfdb56797e19c9b5a1abe9f921446cfcc5b664f73bbbff857cf8d420f588517d4c633d1b3776a35c37fc882 SHA512 c925c290de75d3fa2dfb9e86b2f14ea39279b3f2ab6bebeced72a7853c901d44de02157d684534af2b54edd3a2e0b2ba61e889579ab1b192f99e98a2d73685d9
+DIST bolt-0.9.2.tar.gz 252532 BLAKE2B 45ea8ae2e77a90099152e708dafe68e63492d0370b734612b516d4a772507174c3df75ddd7d6bdea4be5022a88e1e286a738d3b8df6a662ef3b0b92ac7328730 SHA512 69e7ffa58a6dbc8a1b14fd7e11e2291fa60227896ead1a449839716b581c6ab0e351d3ed62f9b51c5e44a5a33ba5e23dc5af73a1b4eef87f733b3231d5454e90
diff --git a/sys-apps/bolt/bolt-0.9.2.ebuild b/sys-apps/bolt/bolt-0.9.2.ebuild
new file mode 100644
index 000000000000..b6e173c5433b
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}