summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-05-03 14:59:20 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-05-03 15:02:17 +0200
commit67c192b1117d51b72b9ff638fe0563d00c65c64e (patch)
tree38aa2b01da1edbbc73788e0edec7cbfdc03cb709 /sys-apps/busybox
parentsys-apps/busybox: add 1.35.0 (unkeyworded) (diff)
downloadgentoo-67c192b1117d51b72b9ff638fe0563d00c65c64e.tar.gz
gentoo-67c192b1117d51b72b9ff638fe0563d00c65c64e.tar.bz2
gentoo-67c192b1117d51b72b9ff638fe0563d00c65c64e.zip
sys-apps/busybox: Drop obsolete make-symlinks warning
- USE=make-symlinks is no longer overwriting binaries on the target system, so let's drop the obsolete warning Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.34.1.ebuild8
-rw-r--r--sys-apps/busybox/busybox-1.35.0.ebuild8
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild8
3 files changed, 0 insertions, 24 deletions
diff --git a/sys-apps/busybox/busybox-1.34.1.ebuild b/sys-apps/busybox/busybox-1.34.1.ebuild
index 693ba522154c..c4292394670b 100644
--- a/sys-apps/busybox/busybox-1.34.1.ebuild
+++ b/sys-apps/busybox/busybox-1.34.1.ebuild
@@ -310,14 +310,6 @@ src_install() {
}
pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ -z "${ROOT}" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is really what you want."
- die "silly options will destroy your system"
- fi
-
if use make-symlinks ; then
mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
fi
diff --git a/sys-apps/busybox/busybox-1.35.0.ebuild b/sys-apps/busybox/busybox-1.35.0.ebuild
index dbdaa5ce70e2..826956c9d2f3 100644
--- a/sys-apps/busybox/busybox-1.35.0.ebuild
+++ b/sys-apps/busybox/busybox-1.35.0.ebuild
@@ -311,14 +311,6 @@ src_install() {
}
pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ -z "${ROOT}" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is really what you want."
- die "silly options will destroy your system"
- fi
-
if use make-symlinks ; then
mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
fi
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 9cca9167e60a..b73a93560532 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -310,14 +310,6 @@ src_install() {
}
pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ -z "${ROOT}" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is really what you want."
- die "silly options will destroy your system"
- fi
-
if use make-symlinks ; then
mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
fi