summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-23 05:51:13 +0100
committerSam James <sam@gentoo.org>2021-06-23 05:51:13 +0100
commite0f4cb490c9f0e0cc4a866547933097bf64589f5 (patch)
treeeae795f4989ab58b75e706ecf91f5125fb0c721b /sys-apps/byld/byld-1.0.3-r1.ebuild
parentdev-libs/libverto: drop static-libs in 0.3.2 (diff)
downloadgentoo-e0f4cb490c9f0e0cc4a866547933097bf64589f5.tar.gz
gentoo-e0f4cb490c9f0e0cc4a866547933097bf64589f5.tar.bz2
gentoo-e0f4cb490c9f0e0cc4a866547933097bf64589f5.zip
sys-apps/byld: add missing sys-libs/libtermcap-compat dep
Closes: https://bugs.gentoo.org/728052 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/byld/byld-1.0.3-r1.ebuild')
-rw-r--r--sys-apps/byld/byld-1.0.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/byld/byld-1.0.3-r1.ebuild b/sys-apps/byld/byld-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..2f2785f83302
--- /dev/null
+++ b/sys-apps/byld/byld-1.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Build a Linux distribution on a single floppy"
+HOMEPAGE="http://byld.sourceforge.net/"
+SRC_URI="mirror://sourceforge/byld/byld-${PV//./_}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+# bug #252054
+RESTRICT="strip"
+
+RDEPEND="sys-apps/util-linux
+ sys-libs/libtermcap-compat"
+
+QA_PREBUILT="*"
+
+src_install() {
+ dodoc BYLDING CREDITS README INSTALL FHS PAKING
+ rm MAKEDEV.8 BYLDING CREDITS README INSTALL FHS LICENSE PAKING || die
+
+ insinto /usr/lib/${PN}
+ doins -r .
+}
+
+pkg_postinst() {
+ einfo "The build scripts have been placed in /usr/lib/${PN}"
+ einfo "For documentation, see /usr/share/doc/${PF}"
+}