summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-06-16 06:51:28 -0700
committerMatt Turner <mattst88@gentoo.org>2017-06-16 07:02:22 -0700
commitf299c787bacbbf389046613d7c94f5bbb8e7d98a (patch)
tree4370cd888b6ef8aabee686a8c301ddd56c935331 /sys-apps/cpuid/cpuid-20170122.ebuild
parentwww-client/google-chrome-unstable: automated update (61.0.3128.3) (diff)
downloadgentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.tar.gz
gentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.tar.bz2
gentoo-f299c787bacbbf389046613d7c94f5bbb8e7d98a.zip
sys-apps/cpuid: Version bump to 20170122
Bug: https://bugs.gentoo.org/611924
Diffstat (limited to 'sys-apps/cpuid/cpuid-20170122.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20170122.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20170122.ebuild b/sys-apps/cpuid/cpuid-20170122.ebuild
new file mode 100644
index 000000000000..3c76118816bc
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20170122.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ eapply_user
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install || die "email install failed"
+}