summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-05-19 22:56:02 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-05-19 23:34:57 +0200
commit5736de5c8824257e9060d80f9c8690915564e668 (patch)
tree678f0113bc125951c1a924b4303bdc56c9110b50 /sys-apps/cpuid/cpuid-20200427.ebuild
parentnet-vpn/networkmanager-strongswan: drop old version (diff)
downloadgentoo-5736de5c8824257e9060d80f9c8690915564e668.tar.gz
gentoo-5736de5c8824257e9060d80f9c8690915564e668.tar.bz2
gentoo-5736de5c8824257e9060d80f9c8690915564e668.zip
sys-apps/cpuid: bump to version 20200427
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid/cpuid-20200427.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20200427.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20200427.ebuild b/sys-apps/cpuid/cpuid-20200427.ebuild
new file mode 100644
index 000000000000..c48d21a156d2
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20200427.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+DEPEND="app-arch/gzip"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20200203-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}