summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-04 22:10:52 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-04 22:11:53 +0200
commit3e576098d558450422bb20e3375864f97e27bfe4 (patch)
treeb2fc8e044b7f6d9071f4fa181094c3881a97a9e4 /sys-apps/cpuid/files
parentsys-apps/cpuid: Mark amd64/x86 stable (diff)
downloadgentoo-3e576098d558450422bb20e3375864f97e27bfe4.tar.gz
gentoo-3e576098d558450422bb20e3375864f97e27bfe4.tar.bz2
gentoo-3e576098d558450422bb20e3375864f97e27bfe4.zip
sys-apps/cpuid: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps/cpuid/files')
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-Makefile.patch30
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-fPIC.patch24
-rw-r--r--sys-apps/cpuid/files/cpuid-20150606-Makefile.patch21
3 files changed, 0 insertions, 75 deletions
diff --git a/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
deleted file mode 100644
index a3aab8a50f66..000000000000
--- a/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: cpuid-20110305/Makefile
-===================================================================
---- cpuid-20110305.orig/Makefile
-+++ cpuid-20110305/Makefile
-@@ -1,7 +1,3 @@
--CFLAGS=-g
--ifneq (,$(findstring arch=i386,$(CFLAGS)))
--CISA=-m32
--endif
- CFL=$(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
-
- PACKAGE=cpuid
-@@ -36,14 +32,14 @@ BUILDROOT=
- default: $(PROG) $(PROG).man.gz
-
- $(PROG): cpuid.c Makefile
-- $(CC) $(CFL) -o $@ cpuid.c
-+ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
-
- $(PROG).man.gz: $(PROG).man
- gzip < $< > $@
-
- install: $(PROG) $(PROG).man.gz
-- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
-- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-+ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
-+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-
- clean:
- rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch b/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
deleted file mode 100644
index 80cc6774a188..000000000000
--- a/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -u cpuid-20110305.orig//cpuid.c cpuid-20110305/cpuid.c
---- cpuid-20110305.orig//cpuid.c 2011-03-04 13:25:16.000000000 -0500
-+++ cpuid-20110305/cpuid.c 2011-07-31 01:53:39.647437813 -0400
-@@ -5319,9 +5319,20 @@
- boolean quiet)
- {
- if (cpuid_fd == USE_INSTRUCTION) {
-+#if defined(__i386__) && defined(__PIC__)
-+ asm("push %%ebx\n"
-+ "cpuid\n"
-+ "movl %%ebx, %1\n"
-+ "pop %%ebx\n"
-+#else
- asm("cpuid"
-+#endif
- : "=a" (words[WORD_EAX]),
-+#if defined(__i386__) && defined(__PIC__)
-+ "=r" (words[WORD_EBX]),
-+#else
- "=b" (words[WORD_EBX]),
-+#endif
- "=c" (words[WORD_ECX]),
- "=d" (words[WORD_EDX])
- : "a" (reg),
diff --git a/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
deleted file mode 100644
index f878977ece91..000000000000
--- a/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- cpuid-20150606/Makefile
-+++ cpuid-20150606/Makefile
-@@ -1,9 +1,3 @@
--CFLAGS+=-g
--CPPFLAGS?=
--LDFLAGS?=
--ifneq (,$(findstring arch=i386,$(CFLAGS)))
--CISA=-m32
--endif
- CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
-
- PACKAGE=cpuid
-@@ -44,7 +38,7 @@
- gzip < $< > $@
-
- install: $(PROG) $(PROG).man.gz
-- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
-+ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-
- clean: