summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-01 12:14:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-01 12:14:19 +0100
commita0c03c6661fa9946ff4dd3f84346e01461eca651 (patch)
tree5120819ec6d2787bd11999ff1dd593ac8de2c510 /sys-apps/diffutils
parentnet-misc/wget: stable 1.20.1 for sparc, bug #674170 (diff)
downloadgentoo-a0c03c6661fa9946ff4dd3f84346e01461eca651.tar.gz
gentoo-a0c03c6661fa9946ff4dd3f84346e01461eca651.tar.bz2
gentoo-a0c03c6661fa9946ff4dd3f84346e01461eca651.zip
sys-apps/diffutils: Bump to version 3.7
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/Manifest1
-rw-r--r--sys-apps/diffutils/diffutils-3.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/diffutils/Manifest b/sys-apps/diffutils/Manifest
index 74fc079beea1..93aaa2ed1342 100644
--- a/sys-apps/diffutils/Manifest
+++ b/sys-apps/diffutils/Manifest
@@ -1,2 +1,3 @@
DIST diffutils-3.5.tar.xz 1360996 BLAKE2B a2348911daff19a73a00985e8528888306f88be36bc2b2433bbd1a2a4dd37da06845df718c797b571e85b7f7fdaac8cb0514098b4c14dd634d531d12ba034be6 SHA512 758229637e3703215adf66c5df04126ae594424abaf2cad8f1fa482bd9759e90838c943ef56e0129beb1396f5932ed9337c8396679da3de32e49bb43d423fd6b
DIST diffutils-3.6.tar.xz 1398296 BLAKE2B 1b0a1443f676a1c09d25ad0be4c2d936156da8e690fade9d39d94be3850c502db24c3f508178a51e817437069db2d110fb4577cd67b2cf645c11a1f26a043e3d SHA512 3c159ff1cb7c901b0a57518483566b5740ca3c45aeb8d3004089f052975481db52994cc18592c502c68b0d2a1e22f1f7830f0d8dd9a9ed86de96e28cce9f70c1
+DIST diffutils-3.7.tar.xz 1448828 BLAKE2B d9f115e0ec9b2499545a3bef4e469fb7786d4a95e0a1c8459c885c53e8b1dc797027979e42c53c2a7df4e1e224942bd9ce5214813977af2bcc67f0698ea0c647 SHA512 7b12cf8aea1b9844773748f72272d9c6a38adae9c3c3a8c62048f91fb56c60b76035fa5f51665dceaf2cfbf1d1f4a3efdcc24bf47a5a16ff4350543314b12c9c
diff --git a/sys-apps/diffutils/diffutils-3.7.ebuild b/sys-apps/diffutils/diffutils-3.7.ebuild
new file mode 100644
index 000000000000..4a57d7cd4205
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-3.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="https://www.gnu.org/software/diffutils/"
+SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
+ mirror://gnu-alpha/diffutils/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+DEPEND="app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ # required for >=glibc-2.26, bug #653914
+ use elibc_glibc && export gl_cv_func_getopt_gnu=yes
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # explicitly allow parallel testing
+ emake check
+}