summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-10-08 21:21:11 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-10-21 17:08:17 +0300
commit3b58c3821d247318956da534ca95b838d1ed26f2 (patch)
tree11ac3922c454c63a40358d3b54f1827cf491a8e7 /sys-apps/dstat/dstat-0.7.4.ebuild
parentmail-client/bower: removed obsolete ebuild (diff)
downloadgentoo-3b58c3821d247318956da534ca95b838d1ed26f2.tar.gz
gentoo-3b58c3821d247318956da534ca95b838d1ed26f2.tar.bz2
gentoo-3b58c3821d247318956da534ca95b838d1ed26f2.zip
sys-apps/dstat: version bump to 0.7.4
Adds support for python 3 Now uses EAPI 7 backport fix from: https://github.com/dagwieers/dstat/pull/167/files added missing six dep avoid deprecation warning for importing collections with python 3.7 Closes: https://bugs.gentoo.org/696442 Signed-off-by: Paul Healy <lmiphay@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/dstat/dstat-0.7.4.ebuild')
-rw-r--r--sys-apps/dstat/dstat-0.7.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/dstat/dstat-0.7.4.ebuild b/sys-apps/dstat/dstat-0.7.4.ebuild
new file mode 100644
index 000000000000..66bbf59ec4a3
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples wifi"
+REQUIRED_USE="wifi? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ wifi? (
+ ${PYTHON_DEPS}
+ net-wireless/python-wifi
+ )"
+DEPEND=""
+
+PATCHES=( \
+ "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" \
+ "${FILESDIR}/fix-collections-deprecation-warning.patch" \
+)
+
+src_prepare() {
+
+ # bug fix: allow delay to be specified
+ # backport from: https://github.com/dagwieers/dstat/pull/167/files
+ sed -i -e 's; / op\.delay; // op.delay;' "dstat" || die
+
+ default
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}