summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-12 02:29:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-12 02:30:35 +0100
commit4b7ad3fe22ca92651f2eb030c0b9fef0722730ba (patch)
treed38418d6e9b7e4e1c58bda3cd5d44e9c9d11b1b8 /sys-apps/ed/ed-1.17.ebuild
parentmedia-plugins/kodi-pvr-hts: Cleanup old version (diff)
downloadgentoo-4b7ad3fe22ca92651f2eb030c0b9fef0722730ba.tar.gz
gentoo-4b7ad3fe22ca92651f2eb030c0b9fef0722730ba.tar.bz2
gentoo-4b7ad3fe22ca92651f2eb030c0b9fef0722730ba.zip
sys-apps/ed: Bump to version 1.17
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/ed/ed-1.17.ebuild')
-rw-r--r--sys-apps/ed/ed-1.17.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-1.17.ebuild b/sys-apps/ed/ed-1.17.ebuild
new file mode 100644
index 000000000000..0d33f5f31e92
--- /dev/null
+++ b/sys-apps/ed/ed-1.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="https://www.gnu.org/software/ed/"
+#SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+# Using gzip instead -- the filesize diff is small and lzip uncommon #545344
+SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # Upstream configure script is moronic.
+ ./configure \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin" \
+ --prefix="${EPREFIX}/usr"
+}