summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-09-04 12:45:44 +0900
committerGöktürk Yüksek <gokturk@gentoo.org>2017-09-05 14:45:11 -0400
commite6c60412216a2fe4099119e710ca9af8bea9be04 (patch)
treeefeb012619d0c1a4323e228e11804c16138b48f6 /sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild
parentsys-apps/elivepatch-server: init version (diff)
downloadgentoo-e6c60412216a2fe4099119e710ca9af8bea9be04.tar.gz
gentoo-e6c60412216a2fe4099119e710ca9af8bea9be04.tar.bz2
gentoo-e6c60412216a2fe4099119e710ca9af8bea9be04.zip
sys-apps/elivepatch-client: init version
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild')
-rw-r--r--sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild b/sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild
new file mode 100644
index 000000000000..2645c846f0f1
--- /dev/null
+++ b/sys-apps/elivepatch-client/elivepatch-client-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch installer client working with elivepatch-server"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+SRC_URI="https://github.com/aliceinwire/elivepatch-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-admin/sudo
+ dev-python/git-python[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"