summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 04:38:28 +0000
committerSam James <sam@gentoo.org>2024-02-02 04:38:28 +0000
commit89aa074d970ce73d7492de5c97b449112229988b (patch)
tree1a048671db42a7971401c67651bcb13153408dc0 /sys-apps/ethtool
parentsys-apps/ethtool: drop 6.5 (diff)
downloadgentoo-89aa074d970ce73d7492de5c97b449112229988b.tar.gz
gentoo-89aa074d970ce73d7492de5c97b449112229988b.tar.bz2
gentoo-89aa074d970ce73d7492de5c97b449112229988b.zip
sys-apps/ethtool: add 6.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-6.7.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index 1060c21be59e..8976897d9e11 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1 +1,2 @@
DIST ethtool-6.6.tar.xz 352476 BLAKE2B dfbc5f9a6ac63210d1ae305c2458cc44d38d44fcc272c9b0397a13a93e0aa0a09e3750e330a27dcf4dce796c6bd302c4d4c1fd91faab824a81949c31f1ed3504 SHA512 1e7eae3abe59e6af4bce0ebedd0a7ea84d1b0adc7693a0f03021c4096677096a022fdae521ac02413f9db46ee232b89dd2015a116845aa6ca7686fdda50a5b21
+DIST ethtool-6.7.tar.xz 352772 BLAKE2B 94a6fd8d29ff479eb894fe56bf991f522fff9af5a94c176d06be2819fe2520125cb48dbded229df1a9f5a0308aeaec503c55caf5d248eef87640c7f90f1132ec SHA512 07d13f9a8f980dab73c07e7c68179cfee272f53103c6dfbce1814b768e3313dc671a0cbefc63d4d53a616876bc1f96db8db2444617e4d58d741fae3acf0be524
diff --git a/sys-apps/ethtool/ethtool-6.7.ebuild b/sys-apps/ethtool/ethtool-6.7.ebuild
new file mode 100644
index 000000000000..e2e14f39f01b
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}