summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-12 18:52:07 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-12 19:08:42 +0000
commit9d8fe0cbb0d96023f7ebd281fd71aacae74fbc69 (patch)
tree5d9699bf0488067667a7b2b3ec757c29f16ae14f /sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild
parentsci-chemistry/chemical-mime-data: Drop old (diff)
downloadgentoo-9d8fe0cbb0d96023f7ebd281fd71aacae74fbc69.tar.gz
gentoo-9d8fe0cbb0d96023f7ebd281fd71aacae74fbc69.tar.bz2
gentoo-9d8fe0cbb0d96023f7ebd281fd71aacae74fbc69.zip
sys-apps/fakeroot: Backport patch for glibc-2.24
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild')
-rw-r--r--sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild b/sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild
new file mode 100644
index 000000000000..a2ccf4890aec
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.20.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="http://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug static-libs test"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
+ "${FILESDIR}"/${P}-glibc-2.24.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}