summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2017-09-30 16:29:53 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-09-30 16:41:49 +0100
commita53d23fb7001d7a0967e97877076b7a676f35ac8 (patch)
tree2603a0275f73dc8781d2032ce342d3dd9f740840 /sys-apps/firejail/firejail-0.9.50.ebuild
parentnet-misc/gerbera: Version bump (diff)
downloadgentoo-a53d23fb7001d7a0967e97877076b7a676f35ac8.tar.gz
gentoo-a53d23fb7001d7a0967e97877076b7a676f35ac8.tar.bz2
gentoo-a53d23fb7001d7a0967e97877076b7a676f35ac8.zip
sys-apps/firejail: Bump version
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps/firejail/firejail-0.9.50.ebuild')
-rw-r--r--sys-apps/firejail/firejail-0.9.50.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/firejail/firejail-0.9.50.ebuild b/sys-apps/firejail/firejail-0.9.50.ebuild
new file mode 100644
index 000000000000..e1943e7842a7
--- /dev/null
+++ b/sys-apps/firejail/firejail-0.9.50.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Security sandbox for any type of processes"
+HOMEPAGE="https://firejail.wordpress.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="apparmor +bind +chroot contrib +file-transfer +network
+ network-restricted +seccomp +userns x11"
+
+DEPEND="!sys-apps/firejail-lts
+ apparmor? ( sys-libs/libapparmor )"
+RDEPEND="${DEPEND}
+ x11? ( x11-wm/xpra[client,server] )"
+
+PATCHES=( "${FILESDIR}/${PV}-contrib-fix.patch" )
+
+RESTRICT=test
+
+src_prepare() {
+ default
+ find -name Makefile.in -exec sed -i -r \
+ -e '/^\tinstall .*COPYING /d' \
+ -e '/CFLAGS/s: (-O2|-ggdb) : :g' \
+ -e '1iCC=@CC@' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apparmor)
+ $(use_enable bind)
+ $(use_enable chroot)
+ $(use_enable contrib contrib-install)
+ $(use_enable file-transfer)
+ $(use_enable network)
+ $(use_enable seccomp)
+ $(use_enable userns)
+ $(use_enable x11)
+ )
+ use network-restricted && myeconfargs+=( --enable-network=restricted )
+ econf "${myeconfargs[@]}"
+}