summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-12-04 22:15:24 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-12-04 22:16:13 +0000
commita4b8ed5f3e50cc472b7edcb824ea9b2b60272358 (patch)
tree519c3bc928081f7453eb34fe4108f8720a014364 /sys-apps/firejail/firejail-0.9.56-r1.ebuild
parentsys-apps/firejail: Remove older versions (diff)
downloadgentoo-a4b8ed5f3e50cc472b7edcb824ea9b2b60272358.tar.gz
gentoo-a4b8ed5f3e50cc472b7edcb824ea9b2b60272358.tar.bz2
gentoo-a4b8ed5f3e50cc472b7edcb824ea9b2b60272358.zip
sys-apps/firejail: Prepare for xpra removal
Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Diffstat (limited to 'sys-apps/firejail/firejail-0.9.56-r1.ebuild')
-rw-r--r--sys-apps/firejail/firejail-0.9.56-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/firejail/firejail-0.9.56-r1.ebuild b/sys-apps/firejail/firejail-0.9.56-r1.ebuild
new file mode 100644
index 000000000000..6da35dbc147b
--- /dev/null
+++ b/sys-apps/firejail/firejail-0.9.56-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Security sandbox for any type of processes"
+HOMEPAGE="https://firejail.wordpress.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apparmor +chroot contrib +file-transfer +network
+ +seccomp suid +userns x11"
+
+DEPEND="!sys-apps/firejail-lts
+ apparmor? ( sys-libs/libapparmor )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-contrib-fix.patch" )
+
+RESTRICT=test
+
+src_prepare() {
+ default
+ find -name Makefile.in -exec sed -i -r \
+ -e '/^\tinstall .*COPYING /d' \
+ -e '/CFLAGS/s: (-O2|-ggdb) : :g' \
+ -e '1iCC=@CC@' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apparmor)
+ $(use_enable chroot)
+ $(use_enable contrib contrib-install)
+ $(use_enable file-transfer)
+ $(use_enable network)
+ $(use_enable seccomp)
+ $(use_enable suid)
+ $(use_enable userns)
+ $(use_enable x11)
+ )
+ econf "${myeconfargs[@]}"
+}